OpenSolo 4, compas calibration error

Joined
Feb 21, 2020
Messages
16
Reaction score
4
Age
40
It is like a lottery with solo 4.0.1. I updated 2 birds and only one worked ok. I ended up replacing the gps and compass with a gps unit that has the compass built in as described above. It solved the issues and the units get much more satellites.
 
  • Like
Reactions: MrBBey
Joined
Mar 12, 2016
Messages
3,923
Reaction score
2,613
It is like a lottery with solo 4.0.1. I updated 2 birds and only one worked ok. I ended up replacing the gps and compass with a gps unit that has the compass built in as described above. It solved the issues and the units get much more satellites.
So you had a hardware problem that has nothing at all to do with Open Solo or ArduCopter...
 
Joined
Feb 8, 2017
Messages
172
Reaction score
53
Age
59
Sounds more like your hardware wasn't working right and the old version was just not noticing it. Updating firmware does not cause hardware to fail.

That’s an interesting point. Does OS4 and/or Arducopter4.0.1 have narrower tolerances than the previous versions of each?
 
Joined
Dec 27, 2015
Messages
19
Reaction score
5
Location
Northern Kentucky
Same here upgraded my solo to 4.0.1 and now the compass will not calibrate. It has to be a parameter setting. Anyone have any luck ?
 
Joined
Sep 1, 2020
Messages
39
Reaction score
0
Age
46
Location
Dallas, TX
Don’t know what to tell you. Same thing happened to me. I circled the quad shoulder level and then same thing but nose down. Waited for the red bar to fill up but never told me it was complete or to reboot.

Did you get it to work?
 

New Threads

Members online

Forum statistics

Threads
12,641
Messages
145,160
Members
14,804
Latest member
Rubic0n