3dr Solo Level Error out of the box

Joined
Feb 10, 2017
Messages
1
Reaction score
0
Age
57
ISSUE:
Received the backpack bundle 3dr solo and when capturing satellites it would give a level error and go back to looking for satellites and give level error again (satellites inside 0 outside 9).Ordered the MRO GPS u-blox Neo M8n/ 3dr solo upgrade($80) and it would capture 15 satellites inside, but still had level error
on the controller, on known level surface. Anyway took the drone apart (instructions online) and found the black wire for the buzzer smashed between the screw mounting nearest the battery connector and the main circuit board. Turns out that this pushes that corner of the main board down, the main board is sandwiched between the battery tray and the airframe and sets the level reference for the drone. So when they calibrated level at the factory it wasn't actually level. To measure the level of the solo put the level on one of the motor spindles, because the battery sits about 3 degrees off level. This board should have been calibrated before being installedin the drone ( this way they would know something was wrong before it left the factory) and of course it should be assembled correctly.

FIX:
Once whatever is causing the main board to be unlevel is corrected, run mission planner and do a accelerometer calibration, connect wifi to sololink and use UDP to connect then do accelerometer calibration. Then run tower on andriod and do accelerometer calibration. Then run solo app and do level calibration. This is the way I did it after mission planer and solo app still would not level calibrate, gave failed. When I ran tower it said on the left successfull but on the right it said failed,then I ran solo level calibration and it went through fine, before it would get stuck on the first page then say failed after a time.

ALSO:
There may be solo's that still fly but you have to fight with level errors and you end up having to make it unlevel to get to the fly screen. the key is to have the main board level to the airframe, the accelerometers are mounted in the black cube mounted on the mainboard. When installing the battery tray jiggle it until the
it seats near the battery connector(there are two slots in the battery board that the tray has to fit into), it should set flush in the body of the drone and your battery should fit in and out nicely.

Haven't flown the solo yet, but now that it gets to the fly screen I plan to do it this weekend.

It's to bad what has happened to 3dr, but the people that went into to the design of this, did a great job!, That includes all the open source contributors as well!!

Thanks for listening
 
Joined
Jul 1, 2015
Messages
654
Reaction score
163
Age
44
mine fixed just factory reset the both drone and controller and calibrate again.
 

New Threads

Members online

Forum statistics

Threads
12,098
Messages
141,224
Members
14,018
Latest member
Solo cowboy