Welcome to 3DRPilots.com

Sign up and join the largest 3D Robotics drone community!

  1. calistogasolo

    Joined:
    Mar 17, 2017
    Messages:
    88
    Likes Received:
    1
    Does anyone know what Generick Mavlink means when Solex is referring to a Solo that is currently connected ?
     
  2. carpy

    Joined:
    Mar 10, 2016
    Messages:
    229
    Likes Received:
    85
    Location:
    Plymouth, MN
    Take a look at Kelly's release notes for this latest release--I believe he made some changes to support other vehicles other than Solo. Solo uses Mavlink 1.0 I believe and is a little old...
     
  3. Pedals2Paddles

    Joined:
    Mar 12, 2016
    Messages:
    3,049
    Likes Received:
    1,882
    It's for custom built vehicles, not solos.
     
  4. calistogasolo

    Joined:
    Mar 17, 2017
    Messages:
    88
    Likes Received:
    1
    What I'd really like to know is how to et my Solo from spinning so maybe someday I can fly it again.
     
  5. Maddog

    Joined:
    Aug 24, 2015
    Messages:
    3,933
    Likes Received:
    1,073
    Location:
    Phoenix, Az
    You mean it spins like it's constantly yawing?
    More details would help us help you.:)
     
  6. Pedals2Paddles

    Joined:
    Mar 12, 2016
    Messages:
    3,049
    Likes Received:
    1,882
    This has absolutely nothing to do with the problem you're having. Please try sticking to the posts and topics you've already made on this matter, and actually follow up to those topics where people are trying to help you. Honestly I don't know why I'm even responding since you've been doing this crap for months now.
     
  7. Kelly Schrock

    Joined:
    Nov 8, 2015
    Messages:
    148
    Likes Received:
    135
    Generic Mavlink is what it falls back to when it tries to ID the vehicle it's connected to and can't find anything else. If you're actually connected to a Solo, then let Solex download the parameters from it before you open the flight screen. Then it will be the right type.
     
    XevetS and carpy like this.
  8. Thomannjf

    Joined:
    Nov 22, 2016
    Messages:
    165
    Likes Received:
    19
    .well, I am right there actually connected to solo. I waited for parameters to down load and I’m still stuck there. I’ve reloaded several times and cannot get any further. Call me dumb, call me stupid, but please call me.
     
  9. Kelly Schrock

    Joined:
    Nov 8, 2015
    Messages:
    148
    Likes Received:
    135
    OK, so you connect to the Solo, see the message showing parameters being downloaded, it completes, then you open the flight screen and it shows "Video not supported"? That indicates that for some reason, it's not seeing your Solo as a Solo. Obviously it shouldn't be doing that, and I'm wondering why it's the case. One thing I suppose I could do is make it where you can force a given connection to be a specific vehicle type. It shouldn't be necessary at all, but for some reason it appears it is in your case.

    Thanks,
    Kelly
     
  10. Thomannjf

    Joined:
    Nov 22, 2016
    Messages:
    165
    Likes Received:
    19
    I’m at that time. Target practice seems to be in order, however, in the spirit of the season,I shall make a strategic withdrawal. I shall return. See ya next year and a Merry Christmas.
    Thanks again.
    Joe Thomann