Joined
Dec 29, 2016
Messages
19
Reaction score
4
Age
46
Does anyone have extensive experience with Tower that can maybe explain what happened? Here goes: I was testing out the Tower app and had loaded a survey grid, launched and solo went up to about 30 feet and hovered but did not continue on its mission. I couln't figure out if there was another step I was missing to get it to initiate the mission so I landed it. I needed to do some other aerial video so decided to switch back to the Solo app, closing the tower app. When I launched Solo this time it took off and Solo voice says something like "waypoints loaded" at which point it seemed like solo was about to start the sequence I put in through Tower, so I paused the drone and tried to land it but it began to drift and wouldn't respond to the controller except altitude commands...so I brought it lower to the ground so at least it wouldn't crash from high up and it drifted about 100 yards away and was heading towards one of the buildings on the property (farm) so I basically brought solo to the ground and she flipped over...thankfully with no damage. All the while it was drifting I hit RTH and pause to no avail.
So, a couple of 3 questions because this is not the first time I've had a flyaway after using the Tower app.
1.) Has this evee happened to anyone out there?
2) If a Tower mission is loaded but not completed will Solo automatically try to go to those waypoints? Is there a way to erase the mission from the drone? Reboot?
3) Why didn't I have control and how can I regain control in similar situations?
As I said, I had had a previous incident after using Tower and switching to Solo app and it was an even worse flyaway. At that time I think I may have still had the Tower app open....it said "going for waypoint 1" and then just started flying away though not in the direction of my most recent mission... though I seemed to have better control in that incident... it was as if it had lost GPS signal that time and was drifting so using the visual on the tablet I was able to find my way back a lot closer...the drone was completely out of sight.
Thanks in advance for any insights and help!
 
you have to switch to auto in tower to run the mission
I think its a dropdown near the take off
Honestly have not used tower since Solex added missions
Not sure what caused the drifting, almost sounds like it was flying in alt hold in tower and you switched to the app not sure
logs would tell you
 
Did you also have a geofence or a max distance set? I ran into that issue before when trying to do an orbit shot from a moving vehical. The drone will hit the edge of the fence (or max distance from take off). It won't go forwards but will respond to altitude adjustments. It also sounds like you don't have one of your buttons mapped to "manual" control, in which case hitting "pause" or "fly" will be of little use to you.

Check your settings to make sure you don't have a geofence or a max distance turned on.
 
  • Like
Reactions: Charingo
you have to switch to auto in tower to run the mission
I think its a dropdown near the take off
Honestly have not used tower since Solex added missions
Not sure what caused the drifting, almost sounds like it was flying in alt hold in tower and you switched to the app not sure
logs would tell you
I went over a tutorial and I think I have a better handle on the mission process now. I tried downloading the logs to my Mac in Terminal to no avail...two different methods. Then I downloaded AMP Planner 2 and it wouldn't show the UDP option, not sure what the deal is. It's more worrisome to me that when I'm using the Solo app it the previously loaded waypoints might just kick in. I'd like to know how to nullify those if possible. Thanks for your response.
 
Did you also have a geofence or a max distance set? I ran into that issue before when trying to do an orbit shot from a moving vehical. The drone will hit the edge of the fence (or max distance from take off). It won't go forwards but will respond to altitude adjustments. It also sounds like you don't have one of your buttons mapped to "manual" control, in which case hitting "pause" or "fly" will be of little use to you.

Check your settings to make sure you don't have a geofence or a max distance turned on.
That I'm aware of I had no geofence settings. The thing about the "fly (manual)" button seting occured to me later (of course). But I'm not sure that was the case of this problem because intially it was about to do the waypoints from Tower when I was able to pause it..it was only after that it seemed to be out of my control..almost as if I had lost GPS and wifi..though as I said I was able to control altitude. Thanks for your input!
 
Did you also have a geofence or a max distance set? I ran into that issue before when trying to do an orbit shot from a moving vehical. The drone will hit the edge of the fence (or max distance from take off). It won't go forwards but will respond to altitude adjustments. It also sounds like you don't have one of your buttons mapped to "manual" control, in which case hitting "pause" or "fly" will be of little use to you.

Check your settings to make sure you don't have a geofence or a max distance turned on.
You might find this thread and video helpful:

https://3drpilots.com/threads/new-tower-tutorial.2360/
I found this, thank you!
 

New Posts

Members online

Forum statistics

Threads
13,088
Messages
147,709
Members
16,028
Latest member
DXR