iPhone 6s Plus unable to fetch map data ?!?

Twd

Joined
Oct 3, 2015
Messages
15
Reaction score
0
Age
50
After opening the new 2.0.0 Solo app on my iPhone 6s Plus a message appears saying that an airport is nearby, which is correct. I tap on the "i" in the message and a "Planning" window appears, briefly loading map data. I change the Filter to "satellite" and a satellite map appears. If I drag the map or zoom out more map data is fetched. That much works flawlessly.

BUT... after I close the Planning window and tap the Fly button, then swipe left twice to display the satellite imagery that's supposed appear all I get is a dark grey grid (with a PIP image from my GoPro). Similarly, if I choose a Smart Shot no satellite imagery is shown; just a grey grid.

I've consulted with 3DR support about this. After removing and then reinstalling the Solo app, they had me switch the iPhone's wi-fi setting from the Solo to my LAN wi-fi because the Solo app is supposed to fetch map data via wi-fi without being connected to the Solo. They said the Solo doesn't even need to be present for their app to fetch map data. However, even via wi-fi the satellite imagery does not appear.

The 3DR tech walked me through verifying that all the relevant iPhone settings are correct. Cellular data is on, the Solo app is enabled to use it, etc. At that point the 3DR support tech said they "have lots of iPhone 6s Plus users and no such complaints so the problem must be at my end, not theirs." I replied that since the Planning function can fetch map data this proves my phone is capable of doing its part. Their reply: the "nearby airport 'planning' function" is from a third party and irrelevant.

Note that I had the same problem with version the Solo version 1.x app.

Any suggestions? Do any other iPhone 6s Plus users have this problem?

-------------------

I found the answer.

First, note that I'm using the Solo in a rural area. Also note that I haven't intentionally used Apple's Maps app in years because I prefer the Google Maps app. Lastly, note that I learned from 3DR support that they have reports of people experiencing the above described problem because the app starts out at a "zoom level" (magnification?) for which there are no tiles available. Zoom out (in my case two "reverse pinches") and tiles will start to load.

But the better more complete solution is: open Apple's Maps app and let it find your flight location. Zoom in as far as you can, etc. You can then close (and stop) that app if you want. Open the Solo app. Maps appear quite quickly. From then on the Solo app seems able to pull down tiles readily even if I change locations. Maybe there's caching going on, but as a test I drove several miles to the other side of our nearby town, opened the Solo app, and appropriate map tiles appeared -- without first using Apple's Maps app. I also cleared the history in the Maps app and still the Solo pulls tiles in quickly. Also worth noting is now when I zoom in too far in the Solo app the tiles now have additional graphics that indicate the absence of tiles (whereas, before, the gray grid was featureless). There's something magic about "priming the iPhone" with a quick use of Apple Maps!

In the process of sorting this out I tried the Solo app on a Nexus 7. After selecting Google Maps as the tile source in its settings (a choice available only in the Android version of Solo) I discovered that I can zoom in MUCH more than with the IOS Solo app that relies on Apple Maps (which offered zoom levels more like those from Mapbox, in my tests).

I wrote 3DR imploring them to add the option of using Google Maps as the tile source in the IOS Solo app.
 
Last edited:
Joined
May 6, 2015
Messages
400
Reaction score
226
Age
61
While connected to Solo wifi, the app tries to load map data by your 3G/4G connection.
I have never experienced any problems on my iPhones, iPad nor on my Android Nexus tablet.

The new planning map function uses Google maps, while Solo is using Mapbox by default. So there could be a different behavior. Can you access Mapbox maps independent from Solo app?
 
Joined
Jun 14, 2015
Messages
1,553
Reaction score
837
Age
122
After opening the new 2.0.0 Solo app on my iPhone 6s Plus a message appears saying that an airport is nearby, which is correct. I tap on the "i" in the message and a "Planning" window appears, briefly loading map data. I change the Filter to "satellite" and a satellite map appears. If I drag the map or zoom out more map data is fetched. That much works flawlessly.

BUT... after I close the Planning window and tap the Fly button, then swipe left twice to display the satellite imagery that's supposed appear all I get is a dark grey grid (with a PIP image from my GoPro). Similarly, if I choose a Smart Shot no satellite imagery is shown; just a grey grid.

I've consulted with 3DR support about this. After removing and then reinstalling the Solo app, they had me switch the iPhone's wi-fi setting from the Solo to my LAN wi-fi because the Solo app is supposed to fetch map data via wi-fi without being connected to the Solo. They said the Solo doesn't even need to be present for their app to fetch map data. However, even via wi-fi the satellite imagery does not appear.

The 3DR tech walked me through verifying that all the relevant iPhone settings are correct. Cellular data is on, the Solo app is enabled to use it, etc. At that point the 3DR support tech said they "have lots of iPhone 6s Plus users and no such complaints so the problem must be at my end, not theirs." I replied that since the Planning function can fetch map data this proves my phone is capable of doing its part. Their reply: the "nearby airport 'planning' function" is from a third party and irrelevant.

Note that I had the same problem with version the Solo version 1.x app.

Any suggestions? Do any other iPhone 6s Plus users have this problem?
Works fine on my iPhone 6S+
 
Joined
Jan 2, 2016
Messages
16
Reaction score
1
Age
41
Location
Redwood Shores, Redwood City, CA
I saw something like this on my Nexus 9 with Android 6.0.1 yesterday. I upgraded the app and 3DR services to the latest versions, and have internet access setup through my phone for the Solo wifi network. When I opened the Solo app on my tablet, even though I had working Internet on the phone, it said no Internet.
 

Twd

Joined
Oct 3, 2015
Messages
15
Reaction score
0
Age
50
See solution at the bottom of my original post. Thank you to all who replied.
 

Members online

Forum statistics

Threads
12,961
Messages
146,910
Members
15,570
Latest member
Johnny99