Gimbal acting weird - is it salvageable?

Joined
Sep 9, 2017
Messages
14
Reaction score
0
Age
38
Im new, please go easy & pretend I don't know anything - cause I basically don't. My gimbal points up to the underside of the drone and is unresponsive to the controller. The led on the back of the gimbal randomly switches between breathing green and breathing red lights. Even when green, its unresponsive. It will also sometimes shake. It gets extremely hot - i now have a blister from where I touched the metal semicircle that sticks out to left of the gopro. It does transmit video feed - damn thing just won't move up or down. Also, it does seem to stabilize the camera ok if I move the solo around by hand.

My troubleshooting steps so far:
1. Unscrew/unplug it all and reinstalled it making sure cabling was out of way
2. factory reset of the controller and the solo & then updating all. (had gimbal attached during process)
3. level calibration (had to remove gimbal for success. Error with Gimbal attached when placing on left side, repeated many times)
4. compas calibration
5. sticks calibration per these instructions: http://thepaperfile.com/public/3dr/calibration.sticks.mac.pdf

System Info screen shows versions:
App 2.4.3
solo 2.4.2
autopilot 1.3.1
gimbal 1.3.6
controller 2.4.2
controller firmware 1.2.11

Backstory: Cousin has a solo and loves it, so I recently bought this one on craigslist (solo, backpack, prop guards, extra battery, extra props, lighting kit, & gimbal all for $200). Seller said he had a rollover on landing which broke 2 props, otherwise never crashed. Cosmetically everything is perfect and it flies fine, at least for my short test flight where I just had it hover 6 feet of ground and land. If I wanted to fly without a camera, id use my little Hubsan trainer. The point of this quad to me was the videography.

Are there any other diagnostics or troubleshooting steps I can do? I sent a request a couple days ago via the app and included the last few flight logs but haven't heard back yet. Ive searched the threads and can't seem to find similar gimbal behavior. If you have any suggestions or think its just toast, please let me know.
 
Joined
May 9, 2017
Messages
1,503
Reaction score
590
Age
40
Sounds like the On-board IMU is hosed. And/or the encoder on the pitch/tilt axis is shot/sending bad values to the on-on-board controller.
 
  • Like
Reactions: averagejoe805
Joined
Aug 24, 2015
Messages
4,255
Reaction score
1,214
Location
Phoenix, Az
I think the problem is in the gimbal- you will probably need to get another one to find out. (Never hurts to have a spare if I'm wrong. I know, the prices have gotten high).
I'm not sure but I don't think 3DR will warranty anything not purchased from an authorized reseller.
 
  • Like
Reactions: averagejoe805
Joined
Sep 9, 2017
Messages
14
Reaction score
0
Age
38
Thanks for the replies! Looks like I'm shopping for a gimbal. Used eBay gimbals worth trying or stick to new?
 
Joined
Nov 22, 2016
Messages
220
Reaction score
28
Age
75
I recommend you go new. Every time I try to save a buck on Solo it cost me ten. That being said, if you go used make sure it is a refurb that you can return.
 
  • Like
Reactions: Maddog
Joined
Aug 31, 2017
Messages
445
Reaction score
196
Location
USA
I have a NIB Solo Gimbal if you're US-Based and interested. Send me a PM if you'd like.
 
Joined
Aug 21, 2015
Messages
303
Reaction score
43
Age
69
Just bought a refurbished drone which flies very nicely but I can't get power to the gimbal. I get a picture but the gimbal just flops around. I have tried other gimbals I have that work on my other Solo but when put on the refurbished one will not stabilize. Just flops around.
 

New Threads

Members online

Forum statistics

Threads
12,500
Messages
144,272
Members
14,579
Latest member
litzer