Android incompatibility & Magnetic Interference

Joined
Jun 21, 2017
Messages
240
Reaction score
72
Location
Susquehanna Valley
I can prove across 4 birds and 3 flavors of android, any Solo upgraded through Android 5.0 gets Magnetic Interference that is almost fatal. Re-flashing/updating through another flavor of Android is then a perfect fix. My problem is 5.0 on a Note 3 and the AryaMod ROM. *I am not saying all devices with Android 5.0 but just mine for certain.* This is only with the Solo app, I haven't tried others.
 
Joined
Oct 17, 2016
Messages
934
Reaction score
270
Age
56
Location
Naples, FL
Mag interference has nothing to do with any Android version. Its the two mags on the Solo not agreeing. Your controller is saying magnetic interference?
 
Joined
Nov 8, 2015
Messages
228
Reaction score
216
Age
55
I can prove across 4 birds and 3 flavors of android, any Solo upgraded through Android 5.0 gets Magnetic Interference that is almost fatal. Re-flashing/updating through another flavor of Android is then a perfect fix. My problem is 5.0 on a Note 3 and the AryaMod ROM. *I am not saying all devices with Android 5.0 but just mine for certain.* This is only with the Solo app, I haven't tried others.

Um, no... you can't. Mag interference on the Solo has nothing at all to do with an app. More details are needed. Where was your Solo sitting?
 
Joined
Jan 28, 2017
Messages
145
Reaction score
19
Age
48
Location
Powell river BC Canada
I am having Magnetic interference issue after installing the HERE have tried full factory reset ,controller and bird also the Cube reset (sswt), seems to have difficulty even signing onto app,,ie sometimes wont connect though wifi is connected ...this interference is universal to drones location...???
 
Joined
Jun 21, 2017
Messages
240
Reaction score
72
Location
Susquehanna Valley
If you are flashing firmware which everyone is that wants to fly a Solo. And the flash is interrupted for even 1/1000 of a second you get very strange problems. One is magnetometer warnings, there are possibly half a dozen or more on quads. Binding problems, here again many different ones. I was unlucky enough to have this on another brand of quad where the upgrade was done over USB that was not trust worthy. Once doing an uninterrupted flash all these "mechanical" problems went away.
My belief is many returns of Solos were due to bad flashes. In some cases flashing from another device might be a fix.
I'm not interested in arguing with experts who I agree know way more than I do.
 
Last edited:
Joined
Oct 17, 2016
Messages
934
Reaction score
270
Age
56
Location
Naples, FL
If you are flashing firmware which everyone is that wants to fly a Solo. And the flash is interrupted for even 1/1000 of a second you get very strange problems. One is magnetometer warnings, there are possibly half a dozen or more on quads. Binding problems, here again many different ones. I was unlucky enough to have this on another brand of quad where the upgrade was done over USB that was not trust worthy. Once doing an uninterrupted flash all these "mechanical" problems went away.
My belief is many returns of Solos were due to bad flashes. In some cases flashing from another device might be a fix.
I'm not interested in arguing with experts who I agree know way more than I do.
Are you using Solo stock firmware? Or 1.5.3? Why have you flashed new firmware? Have you done a compass calibration in a suitable area?
 
Joined
Jun 21, 2017
Messages
240
Reaction score
72
Location
Susquehanna Valley
I'm doing a factory reset and then getting new everything. Not even a choice at that point. Where can you show that they push old firmware?
 
Joined
Mar 12, 2016
Messages
3,923
Reaction score
2,614
Basically none of this makes any sense. I don't doubt you are seeing something going wrong. But it has nothing to do with what Android version you're using.
 
Joined
Oct 17, 2016
Messages
934
Reaction score
270
Age
56
Location
Naples, FL
I'm doing a factory reset and then getting new everything. Not even a choice at that point. Where can you show that they push old firmware?
The Solo app will tell you what firmware your using. The 1.5 stuff is not available through the app. Have you calibrated the mags? I think the firmware you will be using is 1.3.2 but I'm not sure. You may be causing your problems yourself. Nothing personal.
 
Joined
Mar 12, 2016
Messages
3,923
Reaction score
2,614
Factory reset will give you I think 2.4.2 on the companion computer and 1.3.1 (maybe 1.3.2) on the Pixhawk.

I'd you're having these problems, I suggest doing a parameter reset on the pixhawk. You will then need to redo the level calibration, and reboot. The. A compass calibration and reboot. The compass calibration must be done outdoors and away from magnetic interference.

Parameter Reset — Copter documentation
 
Joined
Sep 27, 2016
Messages
1,154
Reaction score
305
Age
55
Location
Southern Maryland
I am having Magnetic interference issue after installing the HERE have tried full factory reset ,controller and bird also the Cube reset (sswt), seems to have difficulty even signing onto app,,ie sometimes wont connect though wifi is connected ...this interference is universal to drones location...???

Are you using the compass in the Here or the stock ones?
 
Joined
Jan 28, 2017
Messages
145
Reaction score
19
Age
48
Location
Powell river BC Canada
i took my old rev b and stock compass and put on parts drone that was having magnetic issue as well...finally got parameters reset on that bird and it is loading up as it should...but now neither drone will connect to app...or rather says connected shows as connected in app but under solo settings on app says not connected to vehicle
 
Joined
Jan 28, 2017
Messages
145
Reaction score
19
Age
48
Location
Powell river BC Canada
i used the compass plug from parts drone to splice HERE into, that was experiencing magnetic interference ..is it possible suspect?...should i just remove and reinstall old compass in leg perhaps?
 
Joined
Jan 28, 2017
Messages
145
Reaction score
19
Age
48
Location
Powell river BC Canada
in MP i looked in compass steup ..removed compass 2...no more mag interference loads up ready to fly!..woohoo!...but...app says not connected to vehicle
 

New Threads

Members online

Forum statistics

Threads
12,676
Messages
145,393
Members
14,870
Latest member
3.dr.mcleod