Another newbie needing help with magnetic interference problems...

Joined
Aug 15, 2016
Messages
11
Reaction score
1
Age
23
Hello,

I've hunted through this forum and the web but have failed to get my Solo flying. Hoping for some suggestions of what to try next.

Delivery arrived on Saturday. Set everything up, updated the software, and powered on.

Magnetic interference. Moved Solo off the kitchen table into the living room and the error cleared. Now it said searching for GPS. OK, looks good, don't expect GPS to work inside, I've got a video feed on my tablet (Galaxy Tab S2), gimbal tilt responds to the controller, great.

Sunday morning I took it out to a wide open field for a first flight. Powered up, magnetic interference.

Spent the next 3 hours driving around trying different places, including way out in open countryside with nothing around but grass and hills, no metal anywhere near and no radio masts in sight.

Tried multiple times to do a compass calibration but each time the green bar across the top gets half way and no further, despite persisting for more than 5 minutes.

Gave up and took it home. Turned it on back in the living room just to see, and it went straight to searching GPS. So I took it outside into the small garden and successfully did a take off and immediate land (because there's no room to fly). And then it went to magnetic interference again.

I did a factory reset, deleted the app, and started from scratch. Pair the controller, install the app, update the software.

Went back out into a wide open field and immediately got the magnetic interference error again. After several times cycling power to try again, eventually Solo said compass error and asked for calibration. Tried the calibration 4 or 5 times. Each time the green bar would get almost to the end (unlike the morning's half-way max), but then Solo would go silent, the controller would buzz and change from "calibrating" to "compass error.

Ideally I'd return the thing but I bought it from dronesforless.co.uk, assuming that was a UK based operation, only to discover when I got the DHL shipping notice that it is in the USA, which leaves me less than confident about the prospect of getting a refund.

I've ordered a replacement compass leg off Amazon.

I've sent a support request to 3DR from the app, which seemed to send logs but I'm not sure what will be in them given that it didn't get off the ground except that one time.

What should I do next?

If you read this far, thanks! Sorry for the long post but I'm trying to be detailed. And I'm fed up. This is my second drone purchase after I bought a Hexo which never worked either. Eventually got my money back for it, but wish I'd learned my lesson.

Any suggestions for further fixes / investigations would be much appreciated.

Thanks!
 
Why did you do a factory reset? This should be the very last resort and only done if you are familliar with the process or advised by 3DR support. If not done properly, you can even completely brick you Solo.
Some hints on how to do a compass calibration.
Solo Compass Calibration how too?

To me it looks like you have a bad compass -> Hardware problem. Pls contact your dealer for a replacement.
 
I did the reset following some other forum post I came across that claimed to have resolved the same issue... Fortunately it seemed to work and not make anything worse. Sadly it didn't make anything better.

Thanks for that link. I reckon I've tried it all as described but I'll spend some more time lurking in a field getting funny looks from passing ramblers.... The fact that others have had it fail the first few times encourages me to be persistent.

Yes, bad compass seems to fit the picture. Is this common? Glad to see that they're not expensive and are available from Amazon.
 
Even though it's a compas issue, for some reason it helps to do a level calibration first (on a perfectly level surface!). Then take it outside, away from any buildings or streets. Remove all phones, watches, jewelry, etc. When you start the calibration, put the controller down and move a few feet away (but where you can still see the calibration instructions).

You might also try some of the tips here:

Magnetic interference issues
 
Thanks for that.

I did do a level calibration but not right before the compass calibration and probably with the controller not very far away.

I'll try again following your tips. Thanks.
 
I hadn't had a chance to fly for quite awhile, but wanted to do the upgrades so flew in my back yard. I've done that many times, launching from a patio made of slate. Never had a problem but this time I got the interference error. I picked up Solo, while powered on and never seeing that error before, had no idea what to do. While holding it, the error went away. I set it back down and everything was fine. The next day I did it again and the same thing happened. Since it happened after the update, it would seem to me that it's software related.
 
I took a chance and replaced the compass leg.

Just had my first flight!!!!!

Look at all those exclamation marks and you'll see how pleased I am!

It was quite nerve-wracking though. Having suffered the disappointment of a brand new (expensive) gadget failing to work, I found it quite worrying every time there was a slight wobble or drift.

And there were quite a lot of wobbles and drifts, but, by and large, it did what I told it to.

Which was up, turn around, backwards, forwards, down. Amazing how much satisfaction can be delivered by something so simple!

No i have 3 weeks to learn to fly before I go to Africa to scare the wildlife with it.
 
I had this problem when the wifi was on in the GoPro. Haven't had it since we verify wifi off each time. Hope this helps.
 

Members online

No members online now.

Forum statistics

Threads
13,120
Messages
147,974
Members
16,112
Latest member
jnelson1000