Here GNSS Compass Calibration Fails on Solo

Joined
May 8, 2017
Messages
1,199
Reaction score
618
Location
Portland Oregon
Course we could always go old school on this.....
When did you buy the HERE and where did you buy it from? Got a link or anything? That would be a quick way to find out if it's a newer HERE model....
If you do try running 3.7 dev arducopter on the stock cube .... rumor has it that you have to have open solo installed and running properly first..... just a rumor of course.....
 
  • Like
Reactions: XevetS
Joined
May 8, 2017
Messages
1,199
Reaction score
618
Location
Portland Oregon
Yes this is a must I'm running on both a stock and green cube so far no real issues...
Glad to hear it, it's been rainy AF in the PNW, so haven't been flying at all except for that one snow day. I might upload 3.7 to one of my birds today, just to have it ready to go should I get a break in the weather. Glad there's such detailed instructions to follow for loading it up!:D
 
  • Like
Reactions: XevetS
Joined
Dec 11, 2016
Messages
17
Reaction score
2
Age
54
@IrishmanPDX
@XevetS

Running Mission Planner version 1.3.62
Solex version 1.8.3
Solex -> Firmware Updates ->Reset Params
get a "you are sure?" warning with Yes and No. Selected Yes. No further indicator or message from Solex - the warning just goes away.
Refesh of Full Parameter List on Mission Planner (MP) shows SYSID_SW_MREV = 0, so Solex did chnage this value.

But, after reboot of Solo and doing the refesh of the parameter list, I see the value is reset back to 120 which is what it had before I did the reset from Solex
MP still compalins if I try to edit this value on Full Parameter List - saying this value is set to read only (screen shot attached).
However, I was able to edit and write the value in Full Parameter Tree in MP.
Rebooted Solo and noticed the value has been set back to 120 again after refrshing the param list in MP.

HERE GNSS-Original Solo GPS Kit, HERE GNSS M8n "3DR
Bought in January this year. Paul Dinardi said it was his last one (I asked if we could exchange it).
The kit came pre-wired. Its different from the diagram posted earlier.

I tried to capture the wire orientation as best I could, too (attached).
 

Attachments

Joined
Dec 29, 2016
Messages
1,165
Reaction score
386
Location
Somewhere in the Beautiful Nature Coast of Florida
Its normal for it to revert back to 120, try one other thing set the AHRS_ORIENTATION to 26 in Mission planner and try to write the value and test again keep props off and try to calibrate?
But really at this point I'm thinking its a newer HERE??
 
Last edited:
Joined
Dec 11, 2016
Messages
17
Reaction score
2
Age
54
Well, that did not work. :(

Tried rotating this thing every way I can. I also tried while I was rotating in place.

I even tried doing the Live Cal on MP, and that failed too (pic attached).

Got to the point where my arms are tired from rotating it so much.

Dang!

Fortunately, I can still fly my bird with the leg compass, and still use the Here to get the sats, for the time being. I was able to fly it before with just the leg compass and using here for GPS lock (on OpenSolo 3)

I still need to install the green cube, so I think I will give that a go with the leg compass installed and working, and then try to calibrate the Here compass again. But, it sure seems like I have a defective component

If I get the Here2, is there anything special parameter wise to have it working? Or should the firmware for the Green cube handle it OK?

I appreciate the help on this!
 

Attachments

  • Like
Reactions: XevetS
Joined
May 8, 2017
Messages
1,199
Reaction score
618
Location
Portland Oregon
If it was bought from Jesters Drones, I'm pretty sure it was the older model HERE. I believe he had specifically bought a supply of the older models due to the fact the newer models weren't supported unless you were running Open Solo with a Green Cube. I uploaded 3.7 dev myself over the weekend (couldn't fly, heavy rain) and apart from some slight erratic gimbal movement, it seems to work ok (gimbal seems to minutely pan up or down by itself). Anyway it's an option if you don't want to go the Green Cube Route.
 
Joined
May 8, 2017
Messages
1,199
Reaction score
618
Location
Portland Oregon
Aye, I believe Matt mentioned this, it's ok for photography but for videography it's terrible. Anyway, I believe he did end up tracking down the issue, so I'm sure he's working on it.
 
  • Like
Reactions: XevetS
Joined
Jun 22, 2018
Messages
50
Reaction score
15
Age
59
I’ve been following this post with great interest because I recently upgraded one of my Solo’s with a GreenCube and a HERE2, Jester’s was out of the original HERE and also the HERE2 for that matter. Anyways I installed the Cube and HERE2 and went with the 3.6.3 firmware at first with my Compass_Orient value set to 0 like my other G.C., HERE Solo that had the 3.6.1 firmware in it and it seemed to operate correctly, flew it around a couple times without any problems. Today I just got done loading 3.7dev into it but set my Compass_Orient value to 26 and performed my calibrations and reboots. It’s like Really windy out today but as soon as the winds die down I’ll take it out for a couple test flights and let you all know how it works. Don’t really understand why one has to have a different value then the other right now but it passed the calibration’s. Thanks for the information, will let you know how it goes.
 
Joined
Jun 22, 2018
Messages
50
Reaction score
15
Age
59
Well I was hoping to be able to help with Glen’s issue by reporting back with changing the Compass parameter to 26 but I chickened out and ended up reloading the HERE parameters with it set to 0. Little voice in the back of my head kept repeating what Pedal’s says about if you have a HERE you need to load the HERE parameter’s, so that’s what I did. BTW I was able to complete the calibration process with 3.7dev and the HERE2 and flew it twice with two full batteries and everything seems OK. Sorry I was of no help to Glen.
 
Joined
Dec 29, 2016
Messages
1,165
Reaction score
386
Location
Somewhere in the Beautiful Nature Coast of Florida
Well I was hoping to be able to help with Glen’s issue by reporting back with changing the Compass parameter to 26 but I chickened out and ended up reloading the HERE parameters with it set to 0. Little voice in the back of my head kept repeating what Pedal’s says about if you have a HERE you need to load the HERE parameter’s, so that’s what I did. BTW I was able to complete the calibration process with 3.7dev and the HERE2 and flew it twice with two full batteries and everything seems OK. Sorry I was of no help to Glen.
Are you using the GPS/compass or GPS only? I.E. did you connect the Here wire harness to the rear leg compass connector on the main-board?

Since you are using the 3.7 dev version I'm thinking the newer Here drivers are baked in,, so yes then it should be set at 0...
 
Last edited:
Joined
Jun 22, 2018
Messages
50
Reaction score
15
Age
59
I’m using both the Compass and GPS and loaded the HERE Parameters just like I did with my other Solo. This one has the HERE2, G.C., and 3.7dev the other has the reg. HERE, G.C., but has 3.6.3 in it right now.
 

New Threads

Members online

Forum statistics

Threads
11,914
Messages
139,757
Members
13,783
Latest member
jjgghhhuu