Updated Green Cube to 4.4.0 - Here GPS - Can't Arm

Joined
Jan 8, 2017
Messages
112
Reaction score
24
Age
55
Recently got the old bird out of storage - connected via Solex and Side Pilot and saw new 4.4.0 code. Bird was previosly upgraded with Here GPS and Green Cube and running Open Solo 4.0Dev and working fine.

Did the upgrade on the Green cube to 4.4.0 code, all went well. Reinstalled Here compass file as well. All connects up fine, finds plenty of GPS sats but will not arm the motors when fly button is held.

Get error in log in Sidepilot about safety switch - not sure what param may need to be set to go. Here GPS is good blinking green, once the failure to arm happens, get tone from bird and lights on Here GPS blink yellow and then back to green.

Ideas?
 
I would re-run the individual motor tests - Mission Planner/manditory setup/optional/Motor Test.
On my Solos, the motors just start at 7, and with a deadzone of 2, 9 gets written. 100% reliable motor starts. Deadzone slip?

What sound does it make on the motor start attempt? The happy or oh-oh noise?
 
Haven't dug into Mission Planner yet - I get the oh-oh noise.

Here's a snip from the SidePilot log -

22:42:13.64 - [Mavlink] ArduCopter V4.4.0 (6d8efd64)
22:42:13.64 - [Mavlink] ChibiOS: 1ec9f168
22:42:13.64 - [Mavlink] CubeGreen-solo 00540031 31365111 30313330
22:42:13.64 - [Mavlink] RCOut: PWM:1-14
22:42:13.64 - [Mavlink] IMU0: fast sampling enabled 8.0kHz/1.0kHz
22:42:13.64 - [Mavlink] Frame: QUAD/X
22:42:23.46 - [Mavlink] ODID: lost transmitter
22:42:23.46 - [Mavlink] ODID: lost operator location
22:43:48.42 - [Mavlink] Arm: Safety Switch
22:43:49.25 - [Mavlink] ODID: lost transmitter
22:43:49.25 - [Mavlink] ODID: lost operator location

(I get a lot of the lost transmitter/lost operator location messages....
 
Check the Messages tab - as things progress there should be a message regarding the arm failure.
Let it sit for awhile after receiving the motor start prompt, see what messages pop up.

I'm just in from flying - on the 1st take off attempt it wouldn't arm - but moving the drone 5' away solved the issue - possibly hdop. GPS has been a bit rough recently with all the solar storms and CME events...I had a spectacular toilet-bowl yesterday; the post flight map showed a massive divergence between GPS and IMU in some spots.
 
Check the Messages tab - as things progress there should be a message regarding the arm failure.
Let it sit for awhile after receiving the motor start prompt, see what messages pop up.

I'm just in from flying - on the 1st take off attempt it wouldn't arm - but moving the drone 5' away solved the issue - possibly hdop. GPS has been a bit rough recently with all the solar storms and CME events...I had a spectacular toilet-bowl yesterday; the post flight map showed a massive divergence between GPS and IMU in some spots.
I should have been more specific - it's the Mission Planner messages you want to see - they are fairly comprenhensive and should indicate exactly what the arm failure is all about.
 
Yeah now it seems the Solo itself is bricked. Boots up to all green lights on the motors, no tones no nothing.
I'll have to figure out how to flash the solo to open solo. I know the controller is fine and is still running open solo on it.
Found some links on flashing the solo with mission planner but the permalink on Facebook is not accessible to me since I'm not on Facebook.
 
Yeah now it seems the Solo itself is bricked. Boots up to all green lights on the motors, no tones no nothing.
I'll have to figure out how to flash the solo to open solo. I know the controller is fine and is still running open solo on it.
Found some links on flashing the solo with mission planner but the permalink on Facebook is not accessible to me since I'm not on Facebook.
Here are the files: (link)

Open Solo 4 SD Card Images (stock Cube)

Attached is the OpenSolo 4.01 for the Green Cube. Rename from .txt > .apj

Best Luck!
 

Attachments

  • ArduCopter.4.0.1.CubeGreen-Solo.txt
    1.1 MB · Views: 2
  • Like
Reactions: jonbrotherton
Thanks CK! Any decent writeups on doing the process to make sure I don't brick it further?
 
Thanks CK! Any decent writeups on doing the process to make sure I don't brick it further?
Install Open Solo - Instructions.

An alternative is to open Solo (eight screws), and tilt the carrier board sidewise to access the USB port on the Cube. Having done that, it's straightforward to directly flash the Cube from Mission Planner, using the Cube Green .apj file previously provided.
 
  • Like
Reactions: jonbrotherton
Recently got the old bird out of storage - connected via Solex and Side Pilot and saw new 4.4.0 code. Bird was previosly upgraded with Here GPS and Green Cube and running Open Solo 4.0Dev and working fine.

Did the upgrade on the Green cube to 4.4.0 code, all went well. Reinstalled Here compass file as well. All connects up fine, finds plenty of GPS sats but will not arm the motors when fly button is held.

Get error in log in Sidepilot about safety switch - not sure what param may need to be set to go. Here GPS is good blinking green, once the failure to arm happens, get tone from bird and lights on Here GPS blink yellow and then back to green.

Ideas?
In the first copy of 4.4.0 I posted for Solo you'd need to set DID_ENABLE to 0 and set BRD_SAFETY_DEFLT to 0. I have since corrected that so they are 0 by default.
 
Last edited:
Not feeling the love. Sr. Citizen bronx, ny wants to fly before he dies. Solo 3dr won't configure. Etc. Help
I provide this service. I do a few of them every week. You send it to me and I send it back updated, calibrated, and flying.


I also don't mind helping you do it yourself. If you have Facebook I have a group with all the info you need and I can walk you through all of it.
 

New Posts

Members online

No members online now.

Forum statistics

Threads
13,101
Messages
147,799
Members
16,077
Latest member
jollyrancher99