My findings on GPS SHTUFF....

No there is no indication. Reboot everything and try again. Connection in ucenter should be tcp, localhost:500.

FYI, the mavlink serial connection over Solo's wifi SUCKS. It's like 20-30% packet integrity and slow as hell. So don't be surprised if it doesn't work right. Connected to the pixhawk by USB, it works flawlessly.
 
I cannot get the Mavserial pass through to work at all. Is there some indication that MP has opened port 500?

When you load up Mission Planner, and connect to Solo, hit CTRL+F and hit the MAVSerial pass one time. You don't get a confirmation or anything.

Leave MP open and start up U-center. Go to Receiver > Network Connection > New and type in "tcp://localhost:500" It will give you an error in u-center if it doesn't work. If it does, you will get a green flashing connection.

I'm pretty sure you can go to MP and load Galileo too if you wanted. Go to GPS settings, think it's GNSS type...then 71. It's not listed anywhere, but could test it out.
 
  • Like
Reactions: Saijin_Naib
When you load up Mission Planner, and connect to Solo, hit CTRL+F and hit the MAVSerial pass one time. You don't get a confirmation or anything.

Leave MP open and start up U-center. Go to Receiver > Network Connection > New and type in "tcp://localhost:500" It will give you an error in u-center if it doesn't work. If it does, you will get a green flashing connection.

I'm pretty sure you can go to MP and load Galileo too if you wanted. Go to GPS settings, think it's GNSS type...then 71. It's not listed anywhere, but could test it out.

Yeah u-center keeps giving me an error. I'll try again soon.

As far as USB connection, don't I need an FTDI? Straight usb gives me nothing at all.
 
Yeah u-center keeps giving me an error. I'll try again soon.

Funny how when this thread started I wanted to turn on the Galileo constellation, but I finally was able to connect and now I want to DISABLE GALILEO, given all the uncertainty about solution rates.

Problem is twofold : I can't seem to make any changes permanent. And though the GNSS to File process seemed to work once, the "file" it saved was invisible to my pc... No editing possible. (Will Run as Admin fix this?)

My understanding of the Procedure to make changes: Load GNSS parameters from solo using GNSS --> File. Make changes and then use File --> GNSS. Is that correct?
 
I forgot to add that all three constellations were enabled from the factory -- GPS, GLONASS and Galileo.
 
Never Mind...

Section 9.2 of the User Guide shows two ways to save to memory. Trying the easy way first (UBX-CFG-CFG and Save current config).

The second way is the Configuration file save I described earlier, but I had it wrong. You must make changes first then download the file from the GPS unit and re-upload using BBR/Flash checkbox.
 

Members online

No members online now.

Forum statistics

Threads
13,120
Messages
147,973
Members
16,112
Latest member
jnelson1000