RedEdge on Solo

D

Deleted member 12003

Guest
First I'd like to mention that the MicaSense RedEdge appears to be a very nice camera and the Solo seems to be a decent platform for it; I'm looking forward to using it for mapping meadow vegetation in a couple of weeks.

But I'm having a very difficult time connecting to the wifi. The RedEdge is hooked up to the Solo for power -- they don't otherwise communicate from what I understand -- and the RedEdge is configured through a wifi link then using a non-internet html page on the RedEdge accessed from my mobile device (Nexus 5 Android phone) browser. The Solo is controlled as normal via a wifi link from the RC, and I use a separate mobile device (Nexus 9 tablet wifi only) for that.

The problem is I've waited up to half an hour to see the rededge wifi showing up on my phone. (I've also tried an iPad, no different.) I've often given up. A reboot sometimes works -- powering down and the Solo then back up. Once connected, no problem, but I get excited the first time the rededge signal shows up in the wifi list!

I wonder if it's due to living in a neighborhood with commonly 10 or so wifi signals showing up on the list. I understand from the MicaSense documentation that the wifi signal is intentionally weak, and have followed recommendations to hold the mobile device very close to the RedEdge, but that hasn't helped.

I figure most of the market for this setup is in precision ag, so maybe this is an urban problem as on the farm there aren't many wifi signals bouncing around. I'll be using this in a remote area, so if it's wifi signal competition (if that's a thing) I shouldn't have a problem there. But I need to test it here to make sure my protocol works at the remote field site.

Any thoughts or experience with this sort of thing -- wifi competition or improving connectivity, or handling similar problems on the Solo?
 
You can't have WiFi running on the camera. It will interfere with the Solo WiFi and severely reduce range or prevent the Solo from connecting to the Controller.
 
Well, that's pretty scary. I wish there were another option; even a switch to turn on/off Wifi. You only need to connect to it before the flight, to set up imaging. The RedEdge has a GPS receiver and can be programmed to start taking pictures at a given altitude then at a distance interval, so it's working autonomously from the Solo (other than power) or your mobile device once that program is running.

However, I understand from MicaSense that there are quite a few folks using the RedEdge on a Solo, so I'm hoping to reach some of those.

Do you know of another way to do this with the RedEdge?
 
I'm afraid I'm not familiar with the camera. Can you set up the camera and then turn off the camera WiFi? Try this with Solo powered off. Once the camera is set and it's WiFi off, then power up Solo and controller.
 
The camera gets power from the Solo, so you can't disconnect, and I don't see how to turn off its WiFi. It only needs to communicate to set up the program to take pictures, which it initiates at a given altitude -- it has its own compass, IMU and GPS to keep track of where it is, etc., and takes pictures at a specified overlap %. I haven't found any posts from anyone finding its WiFi interferes with the Solo, but I do use a separate mobile device to talk to it from the tablet I use with the Solo.
 
I have flown a large number of flights with RE. I use my iPad for that. The wifi is really low power. My iPad has to be literally 6 inches from the camera to connect. Maybe try that.
 
Thanks, that does seem to help. I also got some help from MicaSense who said to wait to power up the tablet and RC controlling the Solo until after setting up the RedEdge. That seems to help too.

I've also learned a way to not worry about even talking to the RedEdge for setup: just previously set it up to use the Overlap mode, and since they don't recommend manual exposures just use the auto exposure, then just look for the green light for GPS and use the manual shutter to take the picture of the calibration panel. The only time I'd need to talk to the RedEdge would be to change the target altitude, though I could just leave that set to something greater than 50 m, maybe 60 or 70 m. I'm using Tower to run the mission, setting overlaps, specifying a camera (Sentek GEMS V1) with a similar HFOV.
 
thats the same as what i did as well. i also have a camera profile for that camera in Tower.


<cameraInfo>
<Name>Micasense Landscape</Name>
<SensorWidth>4.8</SensorWidth>
<SensorHeight>3.6</SensorHeight>
<SensorResolution>1.23</SensorResolution>
<FocalLength>5.5</FocalLength>
</cameraInfo>


Copy this into Windows Notepad. save as an XML file and load into the CameraInfo folder of the tablet.
 
Cool, thanks, that works! I found out how to create the CameraInfo folder in a 3DRServices folder on Internal Storage in Android, and MicaSense Landscape shows up at the top of the list.
 

Members online

No members online now.

Forum statistics

Threads
13,106
Messages
147,826
Members
16,087
Latest member
caseyKoehn