Welcome to 3DRPilots.com

Sign up and join the largest 3D Robotics drone community!

Problems with new Iris+

Discussion in 'Iris+ Discussion' started by Marsden, Dec 24, 2015.

  1. Marsden

    Joined:
    Dec 24, 2015
    Messages:
    1
    Likes Received:
    0
    Hi guys I have just bought a second hand Iris+ but nothing seems to work. Is there any way you can restart the unit to new. I have tried Mission planner and it seems to have made it worse. I cant connect to the drone from my phone it says MAVLink Error No device found and the controller says no data. Any help would be greatly appreciated.
    Marsden
     
  2. APinero

    Joined:
    Dec 28, 2015
    Messages:
    3
    Likes Received:
    0
    I have a similar problem I did 2 things, 1st I order a new receiver just to be in the safe side that I have control of the aircraft at all times and the 2nd thing I did was update the firmware in the aircraft. I can't tell you which one was the one responsible for the good performance but that's what I did now my Iris Plus is working perfect.
     
  3. Tim Curley

    Joined:
    Jan 30, 2016
    Messages:
    15
    Likes Received:
    0
    Mission planner is the only way I know to set things right. I've done it at least ten times. It can be a real pain. If all else fails and you decide to sell it, please let me know. i can always use some of the parts.
     
  4. sfstrong

    Joined:
    Aug 29, 2016
    Messages:
    12
    Likes Received:
    0
    Location:
    Murray, Utah
    Did you up load the plane prams to erase the FC? You need to do that first then put the quad prams back in the FC
     
  5. pyrate

    Joined:
    May 4, 2015
    Messages:
    4,155
    Likes Received:
    1,628
    Location:
    Frisco Texas
    also try directly connecting to the USB slot on Pixhawk