Cannot load OpenSolo on new solo

Joined
Jul 15, 2023
Messages
11
Reaction score
1
Age
54
I acquired a new solo with a lost password. I stepped through the procedure to reset the solo. I have paired the solo and controller and I see them in solex. It appears to be a black cube solo. I am trying to load OpenSolo 4.0.0 Clean Install on both the solo and the controller but both say that the install is incompatible with the hardware. I ran through this procedure with my first solo and it worked ok though I was thinking there was an install specifically for the black cube.

Has something changed in the install process? Iam homeing to move up to the latest Ardupilot to get mavlink 2.0 but the instructions say I have to install 4.0 first.

Bruce
 
I acquired a new solo with a lost password. I stepped through the procedure to reset the solo. I have paired the solo and controller and I see them in solex. It appears to be a black cube solo. I am trying to load OpenSolo 4.0.0 Clean Install on both the solo and the controller but both say that the install is incompatible with the hardware. I ran through this procedure with my first solo and it worked ok though I was thinking there was an install specifically for the black cube.

Has something changed in the install process? Iam homeing to move up to the latest Ardupilot to get mavlink 2.0 but the instructions say I have to install 4.0 first.

Bruce
It sounds like you're not connected to the Solo when you try the Update. Or it may help to set the Default Vehicle Type to Solo in the App Settings.

Also the current latest ArduCopter doesn't support the Solo gimbal. What do you need mavlink2 for? The latest update that supports the gimbal is a modified version of 4.3.2. You can find that in the Solex firmware page.
 
Last edited:
I acquired a new solo with a lost password. I stepped through the procedure to reset the solo. I have paired the solo and controller and I see them in solex. It appears to be a black cube solo. I am trying to load OpenSolo 4.0.0 Clean Install on both the solo and the controller but both say that the install is incompatible with the hardware. I ran through this procedure with my first solo and it worked ok though I was thinking there was an install specifically for the black cube.

Has something changed in the install process? Iam homeing to move up to the latest Ardupilot to get mavlink 2.0 but the instructions say I have to install 4.0 first.

Bruce
 
Bruce,

I had a similar issue tryng to get opensolo loaded. What I ended up doing is pulling the bird apart to access the black cube usb port. I plugged it into my computer, ran mission planner and went thru the process and directly loadEd the firmware. There is a specific version to load that works with opensolo. If forgot which Version, I think it was in the opensolo docs.

NOTE: when you disassemble the bird to get access be very careful not stress the gray ribbon cable IT IS NOT STRAINED RELIEVED and will break. I suggest using a hot glue gun and run a bead around the ribbon cable to secure it to the board.

the usb port on the cube is located behind the HMDI connect. Just remove the connector and you will see it.

Once you load the new firmware reinstall open Solo if needed

Charlie
 

Members online

No members online now.

Forum statistics

Threads
13,106
Messages
147,826
Members
16,087
Latest member
caseyKoehn