Solex does not recognise Solo anymore. Please Help…

Joined
Feb 16, 2018
Messages
4
Reaction score
1
Age
61
After using successfully Solex for more than 1 year, this morning I had a surprise. My Solex v1.9.2 is not able to recognise anymore my 2 Solos, Solo-A with Green Cube and Solo-B with the standard Pixhawk 2.0: “connected to Vehicle”, “Vehicle type is Copter”. Yesterday, “Vehicle type was Solo” for both vehicles, today is Copter?!
I haven’t done recently any changes to my vehicles, controllers or the app. I uninstalled Solex and re-installed. Although I checked and selected again Default Vehicle Type: Solo, after connecting to vehicle and downloading the parameters, Solex is always deciding that “Vehicle type is Copter”.
Any idea what can I do to sort out this issue. Thanks for your help.
 
Joined
Feb 16, 2018
Messages
4
Reaction score
1
Age
61
I expect it is related to this post by @Kelly Schrock

SoloState
Thanks, you saved my day 😊 Yes, it relates to SoloState post.
To be honest, I didn’t understand the <unknown ssid>" issue explained by Kelly Schrock and which, affected me as well.
The only thing that worked in my case (thanks to blakers81) was to Turn On my Android device’s Location and Solex started to work properly: recognising all the Wifi ssids, including “SoloLink_XXXXXX” and Vehicle Type: Solo.
May be Solex, during the start-up phase, should check if the Location is ON and if it is not, to try to switch it on – if possible, if not, at least show a notification that “it must be on”.
 
Joined
Nov 8, 2015
Messages
211
Reaction score
196
Age
54
Thanks, you saved my day 😊 Yes, it relates to SoloState post.
To be honest, I didn’t understand the <unknown ssid>" issue explained by Kelly Schrock and which, affected me as well.
The only thing that worked in my case (thanks to blakers81) was to Turn On my Android device’s Location and Solex started to work properly: recognising all the Wifi ssids, including “SoloLink_XXXXXX” and Vehicle Type: Solo.
May be Solex, during the start-up phase, should check if the Location is ON and if it is not, to try to switch it on – if possible, if not, at least show a notification that “it must be on”.
That's a pretty good idea, honestly, I'll make a note to put that in place. There are some settings that aren't accessible to apps, but if I can get to it to see if it's on, I'll certainly do that.
 
  • Like
Reactions: Wetstone
Joined
Feb 16, 2018
Messages
4
Reaction score
1
Age
61
That's a pretty good idea, honestly, I'll make a note to put that in place. There are some settings that aren't accessible to apps, but if I can get to it to see if it's on, I'll certainly do that.
Good on you Kelly😊 Your App is one of the best, therefore we should try to keep it that way…
  • It appears that from Android 6.0 and newer, WiFi needs Location turned ON – please see attached, notification from my WIFI Analyzer App, when Location Services are Off.
  • Since I’ve got your attention for the above issue, I will ask you something else, if you don’t mind. Last week I performed a Solo Battery Calibration and I used <Vehicles> from Solex to run the motors and discharge the battery. Once it dropped (13.5V; 3.6V / 3.5V / 3.4V / 3.0V), Solex stopped all the motors automatically, protecting the weakest (3.0V) cell of my old battery, thanks! Can we have a similar new feature in Solex to discharge the battery to Storage level using the motors or/and just Solo On (low current) until it reaches the storage voltage?
Thanks again 😊.Wifi-Location.jpg
 

New Threads

Members online

Forum statistics

Threads
12,095
Messages
141,202
Members
14,016
Latest member
wabknobby