Loosing GPS Lock.

Fil

Joined
Feb 1, 2017
Messages
11
Reaction score
6
Age
47
I took a Solo for a flight a week ago. Everything went perfect. Flew like it suppose to - did a nice orbit shot around water tower. Then hit a home button and it landed exactly where it took off. At that point I had about 50% of battery left, so I decided to fly some more.
With 12 GPS satellites locked (white symbol) got up in the air and suddenly remote starts beeping/vibrating saying that GPS signal is lost. It was showing red symbol for 15 GPS at a time. Solo got into a manual mode. Was a bit windy, so it took some of my heart beating trying to land it safely and knowing that I didn't had much of the battery left, but I managed to land it safely.
So since nothing like that happened before, I am thinking that maybe it needs a reboot? So I turned off Solo and a Controller - grabbed a new battery and powered everything again. Got a satellite lock in no time on a ground. Went up in an air - and same happens again. GPS signal lost - manual mode. Landed it again and put back in a storage.
I've sent a support ticket to SOLO, but still have no reply from them - in a chat session they told me that they got it, but they have a very high workflow and that it should take about two weeks to analyze it.
Meanwhile, I've upgraded the GPS module to mRo GPS u-Blox Neo-M8N, and did some testing in my backyard without propellers attached. I got about 18 satellites in view with a lock on a ground, and then when i pick it up and move it up and down it looses the lock. Moving left to right and rotating doesn't seem to affect a lock as much as altitude change. So with an upgrade I got more satellites but with the same problem.
I did a factory reset on Solo and controller, re-calibrated the sensors/GPS with absolutely no effect.
Wanna see if any of you had similar problem and if you guys have any suggestions on what else I could try.'
Thanks.
 
Joined
Mar 12, 2016
Messages
3,920
Reaction score
2,620
If you are holding it in your hand or leaning over it, it is quite likely it report a loss of GPS. That should be considered normal. When you actually fly it with the mRo, is it working properly? The original GPS sucks. The mRo is rock solid.
 

Fil

Joined
Feb 1, 2017
Messages
11
Reaction score
6
Age
47
Ok. I'll try to go to an open field to test it out again. Didn't wanna risk it at a backyard - not enough room there to do manual flight.
 
Last edited:

Fil

Joined
Feb 1, 2017
Messages
11
Reaction score
6
Age
47
Just did that - flies perfect - Thank You.
 
Joined
Jan 20, 2017
Messages
413
Reaction score
112
The mRo GPS upgrade is rock solid......made locally here just south of San Diego......Bought the upgrade from mRobotics.io last week......Actually went & visited them at their business......

The guys there are rock solid with their knowledge of these birds....they are ex 3dr Robotics employees.......met Christian & Ben ....nice guys.....

Call them with questions...they are more than willing to answer questions regarding these drones.....

These will be the guys to repair your drone once it is out of warranty......
 
  • Like
Reactions: FlyXlsa
Joined
Apr 28, 2016
Messages
203
Reaction score
28
Age
65
So, I recently bought the mRo and have been having poor results. I get very quick lock on large number of satellites but then lose lock repeatedly throughout flight. What would cause that? My rev a and rev b gps equipped solos took longer to acquire fewer satellites but have more reliable lock than the $80 mRos. Any ideas why that would be? I can't imagine that my local cloud cover is worse than the blizzard shown in the solo landing thread!
 

Fil

Joined
Feb 1, 2017
Messages
11
Reaction score
6
Age
47
So, I recently bought the mRo and have been having poor results. I get very quick lock on large number of satellites but then lose lock repeatedly throughout flight. What would cause that? My rev a and rev b gps equipped solos took longer to acquire fewer satellites but have more reliable lock than the $80 mRos. Any ideas why that would be? I can't imagine that my local cloud cover is worse than the blizzard shown in the solo landing thread!
Mine works fine since the upgrade. Try do do the 'cardboard' mod if you haven't done that yet to protect the bottom electronics from the metal shield.
 

Fil

Joined
Feb 1, 2017
Messages
11
Reaction score
6
Age
47
Solo Help customer service is not much help at all. Got an email from them on Jan 30 stating that they are sorry for delay and that they are working on it. Still nothing since that.
 
Joined
Apr 28, 2016
Messages
203
Reaction score
28
Age
65
Mine works fine since the upgrade. Try do do the 'cardboard' mod if you haven't done that yet to protect the bottom electronics from the metal shield.

I had problems on first few flights with mRos flying over water under overcast skies. I got very quick lock on 18+ satellites and took off in 60 seconds but had several disconnects. The Solo always reconnected fairly quickly (less than 60 secs), but I was still a bit concerned. One week later, I tested again with much better results. So, now I'm checking kp on UAV forecast and may add the v2 shield. There seems to be some difference of opinions regarding use of cardboard. The mRos install video shows use of cardboard under the copper shield but some here have warned to use different material because cardboard may absorb moisture.
 
Joined
Jun 26, 2015
Messages
1,224
Reaction score
524
Age
69
Location
Bakersfield, Ca. U.S.A.
I had problems on first few flights with mRos flying over water under overcast skies. I got very quick lock on 18+ satellites and took off in 60 seconds but had several disconnects. The Solo always reconnected fairly quickly (less than 60 secs), but I was still a bit concerned. One week later, I tested again with much better results. So, now I'm checking kp on UAV forecast and may add the v2 shield. There seems to be some difference of opinions regarding use of cardboard. The mRos install video shows use of cardboard under the copper shield but some here have warned to use different material because cardboard may absorb moisture.
I would forget the cardboard and go with the v2 shield. I assume you can still get them from 3DR. Even with the mRobotics upgrade, they work great for me.
 

Fil

Joined
Feb 1, 2017
Messages
11
Reaction score
6
Age
47
I had problems on first few flights with mRos flying over water under overcast skies. I got very quick lock on 18+ satellites and took off in 60 seconds but had several disconnects. The Solo always reconnected fairly quickly (less than 60 secs), but I was still a bit concerned. One week later, I tested again with much better results. So, now I'm checking kp on UAV forecast and may add the v2 shield. There seems to be some difference of opinions regarding use of cardboard. The mRos install video shows use of cardboard under the copper shield but some here have warned to use different material because cardboard may absorb moisture.
You got the point there, and I'm sure the V2 shield is better then the cardboard, but I would at least try the cardboard thing to see if this is your problem or not, since it cost nothing before you spend more $ on overpriced shield. Just my 2cents.
 
Joined
Apr 28, 2016
Messages
203
Reaction score
28
Age
65
Thanks for the input guys. I do have a couple v2 shields that just arrived so I am going to experiment more with rev B and mRos in multiple solos. It looks like one of the solos is more prone to lose gps than the other regardless of which gps board is in place. Ironically it's the newest one.
 
Joined
Mar 7, 2017
Messages
15
Reaction score
3
Age
46
Guys - sorta the same experience here - I'd picked up one of the $299 BB deals, and finaly got around to playing with it. I'd ordered an mro assUming it would be a rev A, but it wasn't. Upgraded anyway, using the 3d printed spacer. Works a treat, grab 21 sats where my original Solo with revb gets 9.

Went for a flight today, maybe 5 minutes in the air sub 150ft just to shake it out and make sure it was all happy. "Fly" mode with manual landing, in the middle of the street where I just took off from on a stunningly beautiful, cloudless Texas day. About 30 seconds after power off, I get a "GPS Lost" and associated red icon - with 20 sats?!

I don't think I ever had that with the rev b, and I didn't have that one with me so I could do a side by side test.

Any thoughts? It probably took 2 minutes to restablish lock, and when it did it was back to 21 sats.
 
Joined
Jan 20, 2017
Messages
413
Reaction score
112
SystemsGuy,

Are you using Solex or the Solo App to fly with........

If you are using Solex version 1.3.3....there is a bug in it........upgrade immediately to 1.3.4
 
Joined
Mar 7, 2017
Messages
15
Reaction score
3
Age
46
SystemsGuy,

Are you using Solex or the Solo App to fly with........

If you are using Solex version 1.3.3....there is a bug in it........upgrade immediately to 1.3.4

Thanks for the warning Bilge - I was flying with 1.3.4 - saw the warning on the facebook group yesterday.

I think it may be me not familiar with Solex - it seems like when I land and disarm, I'm immediately getting the "GPS Lost" warning. I noticed it today, but was losing sunlight too fast to want to experiment.
 
Joined
Mar 12, 2016
Messages
3,920
Reaction score
2,620
Mine lose GPS after landing and disarming sometimes too. I'm not sure what causes it exactly. But I can tell you there is a lot more to having a GPS lock than number of sats and HDOP. So it is likely post landing stuff going on with the EKF routines that cause it to temporarily reject the otherwise good lock. It should require fairly quickly thereafter once the EKF routines settle. So it's not something that indicates a problem at all.
 
  • Like
Reactions: SystemsGuy
Joined
Mar 12, 2016
Messages
3,920
Reaction score
2,620
I have two solos in working condition right now. One has a Rev A, the other has a Rev B. Both have the v2 RF shield. I notice no remarkable difference in performance or behavior. But without the v2 RF shield, the older Rev A GPS is a useless paperweight. I was actually planning to put the B GPS into my primary Solo. But after testing them both with v2 shield, I determined it would be a waste of time. Now, the mRo on the other hand would be a remarkable improvement of both, with or without the shield.
 

New Posts

Members online

No members online now.

Forum statistics

Threads
12,999
Messages
147,103
Members
15,762
Latest member
Socosan Adrian