git.freescale.com

Joined
Feb 2, 2020
Messages
38
Reaction score
7
Age
55
I had some issues yesterday building, and decided to execute the nuclear option and start from scratch. Unfortunately now I get an error about not being able to access git.freescale.com.

It appears to me that this repo might not be coming back up, and the new location is supposed to be the NXP repo on github, but I don't see the directory that it's looking for there (imx/mega-fsl-bsp-release). Does anyone know what this is and where one might get it now? Is this something that could be / has been pushed to the OpenSolo repo?
 
Joined
Feb 2, 2020
Messages
38
Reaction score
7
Age
55
Nothing? Does anyone have a copy of this repo that they can push somewhere? AFAIKT we're dead in the water until we can find this.
 
Joined
Feb 2, 2020
Messages
38
Reaction score
7
Age
55
git.freescale.com is not coming back online, and the link that I posted above is apparently now the official repository for the bits that are missing.

I haven't tested it yet, but changing the URL in the build scripts did fix the build.
 
Joined
Mar 12, 2016
Messages
3,923
Reaction score
2,619
Grrr. I hate when that happens. A few other things have changed over the last two years that required some creative workarounds on the builder. Can you open an issue on our git repo with this information? OpenSolo/OpenSolo
 
Joined
Nov 17, 2018
Messages
68
Reaction score
64
Age
45
Grrr. I hate when that happens. A few other things have changed over the last two years that required some creative workarounds on the builder. Can you open an issue on our git repo with this information? OpenSolo/OpenSolo
Hi

firstly thank you for all your efforts and work on opensolo.

I tried to build OpenSolo from scratch myself today too - and found the same issues I think. Glad to hear there is a way round them, and would very much like to learn about the necessary workarounds.
 
Joined
Nov 17, 2018
Messages
68
Reaction score
64
Age
45
Hi. I had another go at seeing how far I could get building open solo... (using Vagrant + Virtualbox on a Win 10 machine)

I noticed when I git cloned OpenSolo/OpenSolo, and tried to init/update the submodules (which I'm not sure is required), I got an error as follows:
Code:
D:\solo\OpenSolo>git submodule update
Cloning into 'D:/solo/OpenSolo/modules/MAVProxy'...
Cloning into 'D:/solo/OpenSolo/modules/ardupilot-solo'...
Cloning into 'D:/solo/OpenSolo/modules/dronekit-python-solo'...
Cloning into 'D:/solo/OpenSolo/modules/imx6-linux'...
Cloning into 'D:/solo/OpenSolo/modules/imx6-uboot'...
Cloning into 'D:/solo/OpenSolo/modules/mavlink-solo'...
Submodule path 'modules/MAVProxy': checked out '64803861c545292c0b6d30837ce2f4dccbf0f8e2'
Submodule path 'modules/ardupilot-solo': checked out '60d270bbaa949bf90cb90d7a27ca3d2c09c11b90'
Submodule path 'modules/dronekit-python-solo': checked out 'c7df21ec053c7ca70d56d10382effac737d68b33'
error: invalid path 'drivers/gpu/drm/nouveau/core/subdev/i2c/aux.c'
Submodule path 'modules/imx6-uboot': checked out 'b0bd4a36d3ed71e2ba89720b0c46b2342a4af11b'
Submodule path 'modules/mavlink-solo': checked out '811c28d66ee5e3f33e56372ff9dc9e3ce92ade86'
Unable to checkout 'c823ff8fe0516cfc75fa9643e2463e7b5b341b31' in submodule path 'modules/imx6-linux'

However when I downloaded the opensolo git repository as a zip file, and then did vagrant up, vagrant ssh, and then ran solo-builder, it .. I got past the error above. but got this error

Code:
[email protected]:/vagrant/solo-builder$ ./builder.sh

Proceed with build? (y/n):y

Yes! Proceeding with build.

[ tup ] [0.000s] Scanning filesystem...
[ tup ] [0.087s] Reading in new environment variables...
[ tup ] [0.088s] No Tupfiles to parse.
[ tup ] [0.088s] No files to delete.
[ tup ] [0.090s] Executing Commands...
 [                   ETA~=??? Remaining=68 Active=1                   ]   0%.tup/tmp/output-742: Text file busy
tup error: Unable to unlink sub-process output file.
 *** Command ID=742 failed: python tools/assetgen.py resources/assets.cfg src
 [                   ETA~=??? Remaining=68 Active=0                   ]   0%
 *** tup: 1 job failed.

PS - where is the best place to discuss this - either here on 3drpilots, or on ArduPilot/OpenSolo ??
 
Joined
Nov 17, 2018
Messages
68
Reaction score
64
Age
45
I can't get meta-fsl-bsp-release - i.MX Yocto Project Release Layer to work....

UPDATE - I think I got it working in the end with a:

Code:
git clone --branch nxp/dora_3.10.17-1.0.0_GA https://source.codeaurora.org/external/imx/meta-fsl-bsp-release


git.freescale.com is not coming back online, and the link that I posted above is apparently now the official repository for the bits that are missing.

I haven't tested it yet, but changing the URL in the build scripts did fix the build.
 
Last edited:
Joined
Nov 17, 2018
Messages
68
Reaction score
64
Age
45
I tried Carlstone/meta-fsl-bsp-release as a possible source for the missing meta-fsl-bsp-release. UPDATE - This is not correct, the link above from webbbn worked once I used the right git branch

And also ran the builder.sh with the "-a false" flag, so as to not build artoo firmware.

I got a bit further - but there is still maybe an issue with error: pathspec 'dora_3.10.17-1.0.0_GA' did not match any file(s) known to git. Not sure what to do next...

Code:
[email protected]:/vagrant/solo-builder$ ./builder.sh -a false

Proceed with build? (y/n):y

Yes! Proceeding with build.

----------------------------------------------------------------------------
M       meta/recipes-gnome/gtk-doc-stub/gtk-doc-stub_git.bb
HEAD is now at bee7e37... eglibc-initial.inc: Drop duplicate include
----------------------------------------------------------------------------
HEAD is now at af392c2... gst-fsl-plugin: Activate gstreamer AAC decoder.
----------------------------------------------------------------------------
HEAD is now at eb4563b... ntfs-3g-ntfsprogs: Fix runtime dependency for development package
----------------------------------------------------------------------------
----------------------------------------------------------------------------
----------------------------------------------------------------------------
HEAD is now at 07ad83d... linux-imx (3.0.35): Fix Congatec board build to use 3.0.35-4.0.0
----------------------------------------------------------------------------
HEAD is now at 5a12677... README: update branches of layers meta-fsl-demos depend on (danny -> dora)
----------------------------------------------------------------------------
HEAD is now at fc3969f... firefox: add nss libraries to PRIVATE_LIBS and add dependency on external nss, nspr
----------------------------------------------------------------------------
error: pathspec 'dora_3.10.17-1.0.0_GA' did not match any file(s) known to git.
Configuring for imx6solo-3dr-1080p

Welcome to Freescale Community BSP

The Yocto Project has extensive documentation about OE including a
reference manual which can be found at:
    http://yoctoproject.org/documentation

For more information about OpenEmbedded see their website:
    http://www.openembedded.org/

You can now run 'bitbake <target>'

Common targets are:
    core-image-minimal
    meta-toolchain
    meta-toolchain-sdk
    adt-installer
    meta-ide-support

Your configuration files at build have not been touched.
Build environment ready
 
Last edited:
Joined
Nov 17, 2018
Messages
68
Reaction score
64
Age
45
I made some further progress on starting the OpenSolo build -

To address the git.freescale.com issue I changed the following in /vagrant/solo-builder/source_sync.sh

Code:
mkdir -p $source_dir/meta-fsl-bsp-release
# *** This was the original line
#git clone git://git.freescale.com/imx/meta-fsl-bsp-release $source_dir/meta-fsl-bsp-release 2>&1 |  grep -v 'fatal'
# *** I REPLACE THE ABOVE with THIS:
git clone --branch nxp/dora_3.10.17-1.0.0_GA https://source.codeaurora.org/external/imx/meta-fsl-bsp-release/ $source_dir/meta-fsl-bsp-release 2>&1 |  grep -v 'fatal'
cd $source_dir/meta-fsl-bsp-release
git fetch
# *** I also rem'd this out, as I think not needed given the git clone of the nxp/dora branch above
#git checkout dora_3.10.17-1.0.0_GA
cd $build_dir
cp $source_dir/meta-fsl-bsp-release/imx/tools/fsl-setup-release.sh $build_dir

This solves the previous error, and now the ./builder -a false -m solo is running (and has being going for 30 minutes already without an error). I will check in the morning to see if the build worked without further errors.
 
Joined
Nov 17, 2018
Messages
68
Reaction score
64
Age
45
Wow - I think it (building the code for opensolo) worked...for both controller and solo imx6solo targets, but I haven't been able to get the Artoo STM32 firmware to build.

Code:
NOTE: Tasks Summary: Attempted 3100 tasks of which 2809 didn't need to be rerun and all succeeded.

All completed files located in below directories of the Vagrant virtual machine (squashfs, uImage, kernel, u-boot, dtb file, initramfs, rootfs.cpio, etc)
/solo-build/build/tmp-eglibc/deploy/images/imx6solo-3dr-1080p/
/solo-build/build/tmp-eglibc/deploy/images/imx6solo-3dr-artoo/

Completed binaries have been copied to the /solo-builder/binaries/ directory:
total 145M
-rw-r--r-- 1 vagrant vagrant  72M Apr 20 13:22 3dr-controller.tar.gz
-rw-rw-r-- 1 vagrant vagrant   56 Apr 20 13:22 3dr-controller.tar.gz.md5
-rw-r--r-- 1 vagrant vagrant  73M Apr 20 13:22 3dr-solo.tar.gz
-rw-rw-r-- 1 vagrant vagrant   50 Apr 20 13:22 3dr-solo.tar.gz.md5
-rwxrwxr-x 1 vagrant vagrant 229K Apr 20 13:22 artoo_2020-04-20_13-22.bin

In the end I couldn't get the build to work on a WIndows 10 virtualbox+vagant machine, but I did create a Ubuntu14.04 virtual machine manually (running under kvm), and then set up a vagrant user account and symlinks so that it would behave like a vagrant virtual machine. I don't know why the Win10 vagrant box didn't work - as I was careful to turn off git CR/LF conversions when cloning repositories.

My next goal is to try to compile usb_modeswitch for the imx6solo board, so as to allow me to use the usb 4G LTE dongle in flight (and see if I can control the solo over 4G instead of wifi).... Some details here: Cellular Solo
 
Last edited:
  • Like
Reactions: just_bruce
Joined
May 9, 2017
Messages
1,616
Reaction score
655
Age
41
I keep expecting you to say 'And for my next trick.....'
?

Seriously, thank you for taking the time and keeping this thread updated. This software stack and architecture is a little too good to let it fade into the past.
 
Joined
Nov 17, 2018
Messages
68
Reaction score
64
Age
45
I keep expecting you to say 'And for my next trick.....'
?

Seriously, thank you for taking the time and keeping this thread updated. This software stack and architecture is a little too good to let it fade into the past.
Thank you, but really it's folks like Pedals2Paddles (massively so) and webbbn who deserve the credit here. Collectively, the more people who can and do build opensolo and do so from time to time, the more chance we have to keep it alive and maintain the knowhow in the community. AS per PedalsPaddles suggestion above, I have logged an issue on the git repo about the changes needed to freescale repo sourcing.
 

New Threads

Members online

No members online now.

Forum statistics

Threads
12,862
Messages
146,422
Members
15,345
Latest member
valkata752