Controller disconnected from Solo

Joined
Aug 21, 2015
Messages
244
Reaction score
39
Age
68
I have had Solos from the beginning. I'm puzzled with the one I have now. I took off and flew out two batteries and inserted the third then took off again. Then I lost signal with the Solo about 100' away. I have about 15 satellites but I have absolutely no control. Picture is locked up and I can't move the Solo. The controls don't work. The Solo starts to land on its own but the controller doesn't,t say RTH. It barely misses a tree landing. So I cut everything off and try twice more. I connect long enough to take off and it looses connection and returns to home. Again the controls do not work. Any ideas??? Love to fly them but I'm not real techie.
 

Attachments

Joined
Sep 27, 2016
Messages
1,154
Reaction score
305
Age
54
Location
Southern Maryland
Check the tightness and orientation of the controller antennas. Antennas should be pointed down and slight out. See manual for a graphic.
There is a null off the ends of the antennas, so if the are pointed at the Solo it will lose connection pretty close.
 
Joined
Aug 21, 2015
Messages
244
Reaction score
39
Age
68
Hi Andrew and Gary.
I have the FPLVR antennas. I have never lost signal before being at least a half mile away. It had me do a level calibration twice and when I'm sitting right in front of it 3 feet away it will not connect to the drone. I will try to recalibrate but I have never done that before or had to. I'll let you know what happens.
 
Joined
Sep 27, 2016
Messages
1,154
Reaction score
305
Age
54
Location
Southern Maryland
So some folks have been able to correct a variety if issues by opening up the controller and removing and resetting the SD card ( holds the controller OS).
There are instructions somewhere in this forum, but basically remove battery, and remove screws on back of controller. When you split the controller halves, don't go too wide since the cables are short and there is no need to remove them (I think). The SD card should have a spot of glue holding it in, so just peal it off. Remove and reseat. Maybe replace with a dab of hot glue.
 
Joined
Aug 21, 2015
Messages
244
Reaction score
39
Age
68
So some folks have been able to correct a variety if issues by opening up the controller and removing and resetting the SD card ( holds the controller OS).
There are instructions somewhere in this forum, but basically remove battery, and remove screws on back of controller. When you split the controller halves, don't go too wide since the cables are short and there is no need to remove them (I think). The SD card should have a spot of glue holding it in, so just peal it off. Remove and reseat. Maybe replace with a dab of hot glue.
Thanks Andrew. I'll give it a try. Let you know how it goes
 
Joined
Mar 12, 2016
Messages
3,664
Reaction score
2,456
Land mode is the failsafe if you lose both controller link and GPS. So that is presumably what it was doing at the time. I cannot tell you why all this happened though. I agree with starting by reseating the SD card.
 
Joined
Aug 21, 2015
Messages
244
Reaction score
39
Age
68
Hi Pedals. I re-seated the sd card and still have the same problem. Do you think it would fix the problem if I just upgraded to the Microtik R11e-2HnD Wifi card?
 
Joined
Aug 21, 2015
Messages
244
Reaction score
39
Age
68
I have the mR gps card installed and when it loses connection it is so totally that it doesn't even say RTH it just lands
 
Joined
Mar 12, 2016
Messages
3,664
Reaction score
2,456
No, do not change out the WiFi card.

Is the GPS working to begin with? As in you have sats, good HDOP, and it holds position in FLY mode?
 
Joined
Aug 21, 2015
Messages
244
Reaction score
39
Age
68
Yes GPS is working good. When I lose connection to the controller I still have 9-10 sats. The new GPS card works good. What's happening is as soon as it takes off the controller loses connection and the Drone starts to land. I wonder if the antenna is messed up. About two weeks ago I had my first real crash. didn't have any trouble since though as I fly everyday almost. Yesterday I flew out two whole batteries and then when I put the third one in I took off flew about 75' away and I lost all control. It's like I turned off the controller though I didn't. It still had power but I couldn't move the solo..
 
Joined
Aug 21, 2015
Messages
244
Reaction score
39
Age
68
I have had Solos from the beginning. I'm puzzled with the one I have now. I took off and flew out two batteries and inserted the third then took off again. Then I lost signal with the Solo about 100' away. I have about 15 satellites but I have absolutely no control. Picture is locked up and I can't move the Solo. The controls don't work. The Solo starts to land on its own but the controller doesn't,t say RTH. It barely misses a tree landing. So I cut everything off and try twice more. I connect long enough to take off and it looses connection and returns to home. Again the controls do not work. Any ideas??? Love to fly them but I'm not real techie.
If you notice the picture I posted you can see I'm disconnected but I have 15 Sats Locked
 
Joined
Aug 21, 2015
Messages
244
Reaction score
39
Age
68
I have a second solo brand new. I tried to connect the new controller to the old solo but I have never done that before and it wouldn't recognize it.
 
Joined
Mar 12, 2016
Messages
3,664
Reaction score
2,456
OK, hold on. How far away is the Solo getting before it loses connection? If it is only moving a few feet away and losing connection, that is probably a bad WiFI card, or WiFi antennas disconnected from the WiFi card, on either the Solo or controller. Landing immediately is expected behavior when it's only a few feet from the take off location.
 
Joined
Aug 21, 2015
Messages
244
Reaction score
39
Age
68
OK, hold on. How far away is the Solo getting before it loses connection? If it is only moving a few feet away and losing connection, that is probably a bad WiFI card, or WiFi antennas disconnected from the WiFi card, on either the Solo or controller. Landing immediately is expected behavior when it's only a few feet from the take off location.
Yes that's what it is doing. It takes off and immediately lands
 
Joined
Nov 15, 2016
Messages
189
Reaction score
112
Location
Fresno, CA
This does not sound like a case of iMX6 be trippin'.

Have you tried installing the stock antennas and seeing if the problem persists? Could be your special antenna, no?

If the problem persists with the stock antennas, and presumably your phone/tablet does not lose connection to the controller only the solo then I do not think the controller's sd card (super rare), wifi card or antenna are the issue; although there have been some cases where the antenna connectors were not fully snapped into the wifi card when the silicone was applied.

I would really be inclined to think the issue is on the solo side. Either the solo wifi card or antennas.
 
Joined
Aug 21, 2015
Messages
244
Reaction score
39
Age
68
This does not sound like a case of iMX6 be trippin'.

Have you tried installing the stock antennas and seeing if the problem persists? Could be your special antenna, no?

If the problem persists with the stock antennas, and presumably your phone/tablet does not lose connection to the controller only the solo then I do not think the controller's sd card (super rare), wifi card or antenna are the issue; although there have been some cases where the antenna connectors were not fully snapped into the wifi card when the silicone was applied.

I would really be inclined to think the issue is on the solo side. Either the solo wifi card or antennas.
Yes I installed the stock antennas and that did not help. I agree with you I think the problem is with the Solo. I took the controller apart 2 times and reseated the ad card. I need to figure out just where to start looking on the Solo
 
  • Like
Reactions: Barramundi

New Threads

Members online

Forum statistics

Threads
11,945
Messages
139,990
Members
13,826
Latest member
Paulypluga