Welcome to 3DRPilots.com

Sign up and join the largest 3D Robotics drone community!

X8+ Motor Problems

Discussion in 'X8+ Help' started by Juan Pablo Gutierrez, Jun 23, 2015.

  1. Juan Pablo Gutierrez

    Jun 23, 2015
    Likes Received:
    Good day,

    I bought a 3DR X8+ but haven't been able to fly it because motor A (back bottom left) isn't working.
    I have tested the ESC and the motor outside from the frame independently and it works perfectly, but when I put together the copter and do the motor test trough the Mission Planner it just gives a long beep and doesn't work. When I arm it, all the motors start spinning except from that one.
    It is labelled in the connection to the PCB as the No. 8.
    I have also tried using the ESC and motors from a different arm (using/changing other motor and ESC from the copter as the motor and ESC A) and still the same problem.

    What suggestions do you have? Is it a configuration problem in the Mission Planner of PX4? What should I try?

    Hoping for your help,
    Best regards,
    Juan Pablo G.