Solo will not pair after install of OpenSolo 4

Joined
Feb 24, 2016
Messages
34
Reaction score
9
Age
66
Today finally I decided to update my Solo from the latest official (3DR) firmware to Open Solo 4.
I used the Side Pilot app and I followed the instructions

The steps that I followed were:
  1. I downloaded both the controller and the copter firmware on the app
  2. I Installed the firmware on the controller.
  3. Without rebooting the controller, I installed the firmware on the copter.
  4. After the firmware was transferred successfully (I got the confirmation message), I rebooted both the Solo and the Controller.
The controller rebooted and updated itself without any issue. However the Solo was stuck making a warbling tone on boot up and with two yellow lights on the rear and a red and green on the front. I performed a factory reset and tried to pair with the controller - the controller detects the Solo and tries to pair but never succeeds.

Any help gratefully received?
 
Joined
Oct 11, 2016
Messages
7
Reaction score
3
Age
38
Yo folks - battle and on resolved all issues. Test flight when the wind drops tomorrow and looking fwd to the grandson flying it at the weekend

RobertT I’m having similar problems with solo except solo and controller connect but then I get a calibrate compass and then solo and controller disconnect and won’t reconnect.

You mind sharing how you fixed your connection problem please

Thanks
 
Joined
Feb 24, 2016
Messages
34
Reaction score
9
Age
66
RobertT I’m having similar problems with solo except solo and controller connect but then I get a calibrate compass and then solo and controller disconnect and won’t reconnect.

You mind sharing how you fixed your connection problem please

Thanks
Dan

I got to the controller and Solo connected with the Compass Calibration required.
I tried several times in the SidePilot app but it did not work. Then I found a thread on here saying you have to go through all the calibrations in the app in order and the compass last.
So I performed the 3d calibration - took several attempts - then the Level calibration - worked first go and then the Compass calibration. On this last one I realised you need to rotate the solo around every axis you can think of not just in the level plane through 360 degrees. Took a couple of goes but in the end it got there!
 
  • Like
Reactions: OldCoder
Joined
Oct 11, 2016
Messages
7
Reaction score
3
Age
38
Dan

I got to the controller and Solo connected with the Compass Calibration required.
I tried several times in the SidePilot app but it did not work. Then I found a thread on here saying you have to go through all the calibrations in the app in order and the compass last.
So I performed the 3d calibration - took several attempts - then the Level calibration - worked first go and then the Compass calibration. On this last one I realised you need to rotate the solo around every axis you can think of not just in the level plane through 360 degrees. Took a couple of goes but in the end it got there!
The problem I’m having is when it says do compass calibration solo disconnects from the controller and I try to pair them again and they won’t pair. Any ideas?
 
Joined
Oct 18, 2022
Messages
6
Reaction score
1
Age
40
@Dan stern : did you took a look over the controller logs ? (ssh to controller and get all files from /var/log or /log). You must study all the logs (the latest ones) and maybe you have the answer there.
 
  • Like
Reactions: OldCoder

New Posts

Members online

No members online now.

Forum statistics

Threads
12,996
Messages
147,111
Members
15,730
Latest member
Tomy76