Open Solo 4 - can't get flying

Joined
Jan 9, 2016
Messages
32
Reaction score
1
Age
42
Hi guys, like many people I gave up on my solo since 3DR stopped maintaining it. I finally took the courage and time to install open solo 4. Installation went smoothly (or so I think), I did it with sidepilot as I'm on iOS. I did have to use my son's android tablet and buy solex on it because sidepilot would not let me calibrate, which solex did.

Anyway, I tried to get off the ground but all I get is a 2 tone sound. Any idea what this could be?

A few things:

- system seems ready. Controller is paired to solo, I have 8 GPS, app is paired to the wifi. Controller tells me to press and hold fly to start motors, but like I said nothing happens
- I have 2 blue lights in the back, one red one green in the front
- I tried both on sidepilot and solex, same sound
- I'm currently trying to fix the lens on my gopro so there's no camera connected to the solo. Maybe that's the issue but surely it can't be and we can fly the drone without a camera?

Thanks for your help!

(of course I'll answer all questions about details I probably missed!)
 
Last edited:
Joined
Jun 24, 2017
Messages
169
Reaction score
73
Age
54
When you try to arm it, look at the Solex screen and it should show a red bar with a message about why it didn't arm.

It probably needs calibration. Do a careful IMU calibration, then reboot, then do the compass calibration, then reboot again.

I had this problem once and I calibrated using Mission Planner on my PC and the problem went away.

Also if you have the gimbal on the Solo take it off until you get the camera in it. It will burn up trying to balance itself with no camera.
 
Joined
Jul 15, 2015
Messages
286
Reaction score
86
Age
72
As I recall, you have to do the installation on both the controller, and the Solo drone.
 

Members online

No members online now.

Forum statistics

Threads
12,980
Messages
146,998
Members
15,652
Latest member
Gege