Issues installing Open Solo 4.0 via SSH/SCP

Joined
Jul 26, 2017
Messages
3
Reaction score
0
Age
80
  • Hello Pedals2Paddles:
  • This short letter is mainly for you and the rest of 3dr Pilot’s subscribers. I am looking for any help or solution to my present problems related to the installation of Open Solo 4.0 in my stock cube 3DR Solo drone.
  • My questions are the following:
  • Due to the difficulties to connect the Internet between my Controller-Solo and the Tablet ATT K88 (android system 7.1.1), I have not been able to download the Firmware using the Solex App latest version (v2.0.7). This means that I have to use the Firmware Update Via SSH/SCP. I feel more or less conformable with this methodology because I used it three years ago in downloading logs files from a survey mission. According to this metrology and the instructions, which are very easy for both Copter IMX, Controller IMX and Golden Image (Factory Reset) Partition Update, and very short in steps; I could not be able to finish the Copter IMX because at the end (Step 4) I received an error message telling “ Remote side unexpectedly closed network connection “ , as You can see at the screenshot attached. I look at the Web for any solution to this because apparently this is a windows OS error without any success, even thought, I have been applying the most reliable or elaborate solution, from my view point, called Group Policy – and Local Group Policy Editor.
  • For your information a) my OS is a Windows 10 Home Single Language, b) when I started this Firmware Updates my Control and Copter are paired and the control is in Preflight Update state, c) the Copter emit some final sounds and d) the camera ( a GoPro Hero 4 Black) is set horizontally in position. Please any clue to solve this issue. And the second question in case the above is not solved is the following:
  • In looking for the solution to the above point I found another method called Manual SSH install which was publish by Pedals2Paddles years ego. This method is similar to the above one but more elaborate in terms of files you are working on. I found the four (4) files to copy for both Copter and Controller but, I have some doubts about where the directory called /temp/golden is located or this one is generated according to the instructions of Step 2. Are these instructions and files described for both copter and controller still functioning for installing Open Solo 4 version nowadays ?. If there is any change in the instructions, please let me know .
  • I am looking forward to receiving any clue to solve these issues from you guys.


Sincerely,



  • Jorge Posada

  • Screenshot (62).png
 
Joined
May 25, 2021
Messages
2
Reaction score
1
Age
35
I had similar issues where I could not SCP the Open Solo 4 firmware files due to the partition being mounted in read only mode and I could not for the life of me get it to remount as read-write which is embarrassing as I am a linux sysadmin. The only solution I could come up with was to remove the SD card from both the controller and the copter and copy the files over and overwrite the existing files. Its a pain in the ass to remove the SD card as they are glued on and also means disassembling the copter by having to remove the motors but its more time consuming than it is difficult. There are a couple videos on YouTube with instructions on how to disassemble the copter. After reassembling the copter I did a factory reset by holding down the PAIR button while powering on the copter and also did a factory reset on the controller. I have done this on a few 3DR Solo drones and it has worked every single time for me.
 

New Threads

Members online

No members online now.

Forum statistics

Threads
12,828
Messages
146,200
Members
15,236
Latest member
simondh1