Welcome to 3DRPilots.com

Sign up and join the largest 3D Robotics drone community!

  1. Ed.it.Ed

    Joined:
    May 9, 2017
    Messages:
    124
    Likes Received:
    17
    Location:
    22.058755, -159.397287
    and help me stabalize. After updating to Arducopter 3.5 and 3.6 and the accompanying parameters- she's been scary unpredictable. In the air AND on the ground. Leapfrog anyone?




    july3 Q#1 RECENT-1.BIN


    jul3 Q#1 RECENT-2.BIN
     
    #1 Ed.it.Ed, Jul 4, 2018
    Last edited: Jul 4, 2018
  2. Ed.it.Ed

    Joined:
    May 9, 2017
    Messages:
    124
    Likes Received:
    17
    Location:
    22.058755, -159.397287
    Am i not asking nice enough?Pretty please?
     
  3. Ed.it.Ed

    Joined:
    May 9, 2017
    Messages:
    124
    Likes Received:
    17
    Location:
    22.058755, -159.397287
    Do you guys have something against interspecies frolicking?
     
  4. Ed.it.Ed

    Joined:
    May 9, 2017
    Messages:
    124
    Likes Received:
    17
    Location:
    22.058755, -159.397287
    After some research i see that it was not necessary to load Arducopter.

    OpenSolo/documentation

    So its back to Open Solo. Still would like to hear an analysis of the logs. They are in the correct format yes?
     
  5. timgilley

    Joined:
    Sep 18, 2017
    Messages:
    31
    Likes Received:
    7
    I recently bought a used Solo, #3. My pre-purchase test was getting satellites and arming without props. Good enough. My first flight was a new experience. Solo armed and as soon as it lifted started spinning. I was so 'surprised by the antics it took me a moment to gather my thoughts. By then it had flipped and was scooting around on my concrete driveway and broke props. Eventually the motors cut off. I did level cal and compass cal. Second flight in backyard -- grass. Did the spinning on liftoff, but I was ready and landed upright. Came to this site and found the same problem in a thread. Solution was to reset parameters to factory. Seems some character defining parameter was incorrect causing the spin. Third flight -- level and smooth. Lesson: Don't fly a 'strange' drone off your concrete driveway.

    I need to learn how to analyze logs. I work around all kinds of high tech machining equipment, but haven't done a deep dive into the Solo.
     
    IrishmanPDX likes this.
  6. carpy

    Joined:
    Mar 10, 2016
    Messages:
    333
    Likes Received:
    123
    Location:
    Plymouth, MN
  7. Ed.it.Ed

    Joined:
    May 9, 2017
    Messages:
    124
    Likes Received:
    17
    Location:
    22.058755, -159.397287
    Thanks Carpy. That is strange . Never touched it.
    What should the setting be?
     
  8. carpy

    Joined:
    Mar 10, 2016
    Messages:
    333
    Likes Received:
    123
    Location:
    Plymouth, MN
    Should be 0 for GPS only.
     
  9. Ed.it.Ed

    Joined:
    May 9, 2017
    Messages:
    124
    Likes Received:
    17
    Location:
    22.058755, -159.397287
    Actually Setting of 0 means use existing configuration ( default)

    I spoke to someone at mRo and they apolgized saying that in all likelihood someone had set that incorrectly by accident before the GPS left the factory.

    However that does not explain the setting because the data i uploaded was from a flight several days before i had the new GPS.
    So the mystery remains unsolved.

    The good news is after correcting the numbers and reloading the params- its staying put on zero after repeat power cycles.
     
    carpy likes this.