Wild drift (mRo, Opensolo 4)

Zzz

Joined
Feb 13, 2017
Messages
74
Reaction score
44
Location
Eveleth, Minnesota
Website
www.youtube.com
I recently dug my Solo out, upgraded to OS 4, then transplanted the main board and motor pods into a new airframe. Got everything together and had a successful couple flights.

But it's not the stable Solo I remember. I have the mRo GPS and it locks onto 12 or more satellites usually. Seems like it would get to 18 or more when I lived further south (I'm at 47°N now).

It wanders quite a bit laterally, bobs in altitude, and seems to be imparting more vibration to the gimbal than ever. I swapped to my spare NIB gimbal which works ok but the controller now will show "gimbal hardware not found" or something like that. Does that get flashed during the OpenSolo upgrades? Do i need to reflash the copter?

Is it possible something else is damaged on the main board that I didn't notice? I performed IMU and compass calibrations before flying.

It still flies fine under active control but I can't really go hands off anymore or it'll be in the trees after a few seconds.

Ideas?
 
Last edited:
Joined
Jul 17, 2016
Messages
42
Reaction score
2
Age
43
Недавно я выкопал свой Solo, обновился до OS 4, а затем пересадил основную плату и моторные блоки в новый планер. Собрал все вместе и совершил пару успешных полетов.

Но это не тот стабильный Solo, который я помню. У меня есть mRo GPS, и он обычно фиксируется на 12 или более спутниках. Похоже, когда я жил южнее (сейчас я на 47 ° с.ш.), было бы 18 или больше.

Он немного блуждает в стороны, покачивается на высоте и, кажется, придает больше вибрации стабилизатору, чем когда-либо. Я заменил свой запасной карданный подвес NIB, который работает нормально, но теперь на контроллере будет отображаться сообщение «Карданный подвес не найден» или что-то в этом роде. Это мигает во время обновлений OpenSolo? Нужно ли перепрошивать коптер?

Возможно ли, что на основной плате повреждено что-то еще, чего я не заметил? Перед полетом я выполнил калибровку IMU и компаса.

Он по-прежнему отлично летает под активным контролем, но я больше не могу оторваться, иначе через несколько секунд он будет на деревьях.

Идеи?
it helped me Tuning Process Instructions — Copter documentation
 
Joined
Oct 9, 2016
Messages
5
Reaction score
0
Age
52
I recently dug my Solo out, upgraded to OS 4, then transplanted the main board and motor pods into a new airframe. Got everything together and had a successful couple flights.

But it's not the stable Solo I remember. I have the mRo GPS and it locks onto 12 or more satellites usually. Seems like it would get to 18 or more when I lived further south (I'm at 47°N now).

It wanders quite a bit laterally, bobs in altitude, and seems to be imparting more vibration to the gimbal than ever. I swapped to my spare NIB gimbal which works ok but the controller now will show "gimbal hardware not found" or something like that. Does that get flashed during the OpenSolo upgrades? Do i need to reflash the copter?

Is it possible something else is damaged on the main board that I didn't notice? I performed IMU and compass calibrations before flying.

It still flies fine under active control but I can't really go hands off anymore or it'll be in the trees after a few seconds.

Ideas?
The gimbal must be connected during software flash, the software on the gimbal is not actually flashed but the gimbal must be connected for the OS to enable the feature. I had this same exact issue with one of my solo's I upgraded and was testing a crash recovery without the gimbal, once I finished testing I connected the gimbal and Opensolo did not detect it. I also found that the motor pod LED's would not function correctly. I ended up restoring the original 3dr Solo firmware, then upgraded 3dr Solo to 1.3 (latest) then reinstall Opensolo with the gimbal connected. Once all of the re-flashing was complete the gimbal worked fine.

If you motor pod LED's configuration works then you probably can correct the gimbal by re-flashing Opensolo with the gimbal connected.

Additionally both of my Solo's drift after upgrading to Opensolo using the default parameters and the RTL was accurate within about 15 ft of its home position, I have done a lot of tuning to both of mine to stabilize them like the original 3DR Solo and now the RTL is accurate within less than 5 ft of its home position.
 

Zzz

Joined
Feb 13, 2017
Messages
74
Reaction score
44
Location
Eveleth, Minnesota
Website
www.youtube.com
Thanks everyone. The Arducopter tuning instructions seem comprehensive but I'm not quite sure where to start in applying the procedure to Solo.

Should I update my Arducopter to v 4.0.3 per the latest available in Sidepilot? What are some of the other updates in there like "HERE Compass Parameters" for?

@Terry Brown any tips on where to start with stability tuning?

Thanks.
 
Joined
Oct 9, 2016
Messages
5
Reaction score
0
Age
52
Thanks everyone. The Arducopter tuning instructions seem comprehensive but I'm not quite sure where to start in applying the procedure to Solo.

Should I update my Arducopter to v 4.0.3 per the latest available in Sidepilot? What are some of the other updates in there like "HERE Compass Parameters" for?

@Terry Brown any tips on where to start with stability tuning?

Thanks.
I started by setting my EKF to EKF2 instead of EKF3, arducopter 4 is still in testing of EKF3.

Second would be set the PID’s, the P and I gains are quite a bit different from the factory 3DR Solo.

Check the RC throttle end points and trim (I believe this is channel 3) the RC throttle is not set correctly in Opensolo defaults so hover thrust is not correct.

Also set T-Cal to learn.

I am not where I can get to my computer to give you good starting point values but you can search the web to find the 3DR Solo defaults.
 

Zzz

Joined
Feb 13, 2017
Messages
74
Reaction score
44
Location
Eveleth, Minnesota
Website
www.youtube.com
I started by setting my EKF to EKF2 instead of EKF3, arducopter 4 is still in testing of EKF3.

Second would be set the PID’s, the P and I gains are quite a bit different from the factory 3DR Solo.

Check the RC throttle end points and trim (I believe this is channel 3) the RC throttle is not set correctly in Opensolo defaults so hover thrust is not correct.

Also set T-Cal to learn.

I am not where I can get to my computer to give you good starting point values but you can search the web to find the 3DR Solo defaults.
This is good stuff. I'll give it a try this week. Thanks.
 

Zzz

Joined
Feb 13, 2017
Messages
74
Reaction score
44
Location
Eveleth, Minnesota
Website
www.youtube.com
I started by setting my EKF to EKF2 instead of EKF3, arducopter 4 is still in testing of EKF3.

Second would be set the PID’s, the P and I gains are quite a bit different from the factory 3DR Solo.

Check the RC throttle end points and trim (I believe this is channel 3) the RC throttle is not set correctly in Opensolo defaults so hover thrust is not correct.

Also set T-Cal to learn.

I am not where I can get to my computer to give you good starting point values but you can search the web to find the 3DR Solo defaults.
Am I editing the parameters in the table in Solex? I tried changing EKF from 3 to 2 and Solo complained there were "no cores for EKF 2" or something like that.

how do I find the PID's and T-Cal? Tried to filter for these params but couldn't find them. Sorry I'm pretty green with the tuning. Appreciate the help.
 
Joined
Oct 9, 2016
Messages
5
Reaction score
0
Age
52
Am I editing the parameters in the table in Solex? I tried changing EKF from 3 to 2 and Solo complained there were "no cores for EKF 2" or something like that.

how do I find the PID's and T-Cal? Tried to filter for these params but couldn't find them. Sorry I'm pretty green with the tuning. Appreciate the help.
It sound like you don't have everything up-to-date, see attached for a parameter list from mine, I have used these parameters on 2 different Solo's and they both fly very close to the original 3dr Solo.
 

Attachments

  • SidePilot_Params.txt
    96 KB · Views: 4

New Threads

Members online

Forum statistics

Threads
12,893
Messages
146,545
Members
15,418
Latest member
Imflying