Unable to install pre-flight update

Joined
May 16, 2015
Messages
90
Reaction score
54
Age
45
I got my Solo this afternoon. Once charged, I began the update process. It was straightforward until it started looking for GPS and asking me to cycle the drone battery off and on. Then I got a message saying there was a level error and I needed to calibrate the level using the app, but the app wasn't letting me do that and nothing could progress and I had to restart the controller.

Now I'm in a nightmare of not being able to finish the update. It just won't do it. I've restored the factory settings over and over and the update fails right when I try to run it now. Incredibly frustrating. I put in a ticket but will probably need to talk to someone on Monday. I have a feeling I'll have to return it.
 
  • Like
Reactions: GoodnNuff
Did you restart your solo, your remote and app?

Turn on Solo first then after solo is completely on turn on remote then connect tablet to solo. Then at your app try calibrating by going to solo tab and follow the prompt at the app.

Hope that helps. Don't forget to register your copter before you log the ticket or I think it won't let you send the ticket without registering.

Have fun. Safe flight
 
I also had to calibrate the level using the app. Then I went through the compass calibration. It all finished ok but I was a little concerned that I might not be rotating the quad properly.
 
Did you restart your solo, your remote and app?

Turn on Solo first then after solo is completely on turn on remote then connect tablet to solo. Then at your app try calibrating by going to solo tab and follow the prompt at the app.

Hope that helps. Don't forget to register your copter before you log the ticket or I think it won't let you send the ticket without registering.

Have fun. Safe flight
Yep, everything got restarted repeatedly. I can't get the solo tab to open. The drone doesn't seem to want to make that connection.
 
Yep, everything got restarted repeatedly. I can't get the solo tab to open. The drone doesn't seem to want to make that connection.
Same "problem" I had with mine. Just restart everything. Then reconnect to the solo"s wifi. Now just back out of the update screen using the back arrow when the level error pops up. Then select "solo" on the app. The level calibration is there. It will have you put it on its side, then click next on the app. Then it will just walk ya through the process.
 
I think the key is to restart the iPad. It's not enough to exit the app and relaunch the app. Completely power off the iPad, power back up, relaunch the app.
 
I think the key is to restart the iPad. It's not enough to exit the app and relaunch the app. Completely power off the iPad, power back up, relaunch the app.
Yes! I forgot to add this step. Thanks for the correction. ;) All though I did say "restart everything" but you're correct erikgraham!
 
No matter how many times I fully reset everything, i get the update error message. Something is up with the drone.

Other than these software issues, it also came out of the box with a red LED burned out on one of the arms. The two issues are a little much for me. I'll be returning this one in hopes of getting a non lemon.
 
No matter how many times I fully reset everything, i get the update error message. Something is up with the drone.

Other than these software issues, it also came out of the box with a red LED burned out on one of the arms. The two issues are a little much for me. I'll be returning this one in hopes of getting a non lemon.
You failed to mention the burnt LED at first. That's a bit more concerning. :eek:
 
You failed to mention the burnt LED at first. That's a bit more concerning. :eek:
It wasn't obvious at first, but when the drone goes into what I call "unhappy mode", the lights blink red back and forth. At first I thought three red lights was a specific error code until I noticed that when all arms were meant to be purple, the arm with the bad led was blue.

The LED seems kinda minor, I know, but combined with the update nightmare I had, I don't trust the unit I got.
 
I've tried the pre flight update 7 times to no avail. It gets varying amounts through the process each time. Power cycled everything. Calibrated level. And it keeps saying some sort of connection error.

VERY frustrating. Anything else I should try?

Edit: 8 times now. The message says "Transfer failed. Make sure your Controller and Solo are turned on, and you are connected to Solo Wi-Fi and try again."

BRUTAL.

I'm on an iPhone 6+, latest software.

And if it's relevant, level calibration failed three times before it worked.
 
Last edited:
Fixed. Bought an iPad Mini 2 and it worked. I think there was some issue with it staying connected to the sololink network because of my LTE connection. Who knows. Happy it's updated and ready to go on a first flight as soon as it's warm enough.
 
  • Like
Reactions: erikgraham
I have had my solo for over two weeks and have never been able to get it fully functional. When I was able to see the live video feed on the Nexus 7 (2013), I was unable to use the record control, it was simply a gray button. Now when I start up the controller, all I get is a "preflight update" screen. The app says I am up to date with both the controller and the solo version 2.1.1 I have rebooted in every imaginable sequence to no avail. I have also tried using my Samsung Galaxy S7 and I get the same result, or lack thereof.

I am new at this, but I must say it is very discouraging. The project that I bought the solo for has come and gone. Anyone else have these problems?
 
I did experience similar problems. My bird has been RMA twice since then, so cannot say I have these frustrations with current set up. I have seen controller and/or app "fib" and say it needs update or battery out of charge. Agree with Erikgragham, the old complete, hard, power cycle often clears the issue.

I'll agree that if LED not right, they will probably tell you to send it in for replacement.

I'll go a hair off topic here and say, this is where phone support would really help some people. As it did me, overall some of my early issues we simple "order of launch, restart everything". With help of someone right there on the line with you, many problems would be resolved, and customer back up and running, rather than waiting for email reply. Re: they go back to flying and having fun much sooner.

While I consider purchase of a new, second Solo, I am leaning more toward getting it from Best Buy. Wherein if you do get one of the few "lemons" that get out the door, you can march back in/out of the store with a new one right away, (within 30 days) rather than running the support gauntlet with 3DR. Since they are the same price, and 3DR is on the hook to support it anyway, I don't see the down side.

Good luck.
 
Eric

Thanks for your imput! I actually broke down and contacted 3DR. I must say that I was extremely frustrated. I was able to get a tech support guy on online chat and after about 3 hours was able to get the issue resolved. Basically what it came down to is a factory reset. After trying numerous other options he said this was the last option before sending it back in for a replacement. Once I did the complete reset, uninstalled the program on the Nexus 7, updating the GoPro Hero 4 Black (again) and starting from scratch everything eventually went into place. I was able to go out this afternoon and get some stellar footage of a local orchard. I have read other posts about customer support from 3DR that were not so hot, but I am grateful for the help they gave and the time it took to solve my problem.
 

New Posts

Members online

No members online now.

Forum statistics

Threads
13,111
Messages
147,883
Members
16,097
Latest member
massonskyi