Tower Live Video Feed Missing

Joined
Oct 9, 2016
Messages
129
Reaction score
18
Age
42
Hello!

Recently I installed Tower ver. 4.0 on both of my Android devices (Android ver. 4.1.2 and 4.0.4). Till then I used 3DR Solo App on my IPhone 6, IOS 10.0.2, which is still working fine.
Unfortunately I could not get a live video feed on Tower on both Android devices. I have checked the box in Settings-->User Interface-->Widget Preferences-->Solo Video. Tower is showing a black box, which reads "No video available".

Has anyone experienced such a problem before?
 
Joined
Oct 22, 2016
Messages
80
Reaction score
9
Age
44
Silly question on my end but did you connect through UDP I get know live feed until I push connect
 
Joined
Oct 9, 2016
Messages
129
Reaction score
18
Age
42
Silly question on my end but did you connect through UDP I get know live feed until I push connect
Sure, I did connect through UDP, port 14550 (if I am not mistaken).
Everything worked fine on Tower, I made some vibration analysis while in the air. But still no live video feed.
I tried closing Tower and starting 3DR Solo App right after it without restarting Solo, Controller or GoPro. Everything worked fine in the 3DR Solo App.
 
Joined
Oct 9, 2016
Messages
129
Reaction score
18
Age
42
In addition I do not get an RSSI reading at all. Just dashes (---)
 
Joined
Oct 22, 2016
Messages
80
Reaction score
9
Age
44
My port is not specified in settings just say solo stream I'm not using custom stream or port nubmbers! ounce my WiFi is set to solo I define UDP as my connection device my solo stream will not start until connection is established. Sorry I can't help more but here's my steps to getting a video link.
 
Joined
Oct 9, 2016
Messages
129
Reaction score
18
Age
42
My port is not specified in settings just say solo stream I'm not using custom stream or port nubmbers! ounce my WiFi is set to solo I define UDP as my connection device my solo stream will not start until connection is established. Sorry I can't help more but here's my steps to getting a video link.
10x for the advice!
The port that I post d is the one Tower connects to Solo. The Video stream port is Solo video stream (no specific port).
I do not run 3dr services. Do you?
 
Joined
Oct 9, 2016
Messages
129
Reaction score
18
Age
42
I tried installing 3dr services, but it makes no difference: still no live video feed nor RSSI. Maybe the problem lies in the Android OS ver. What Android ver. is your device running?
 
Joined
Jul 4, 2016
Messages
1,442
Reaction score
483
Location
SWFL
Services is no longer required for Tower v4 or the newest 3DR app, but with Android versions 4.x on your devices, you are 2 OS versions behind the curve.
 
Joined
Sep 27, 2016
Messages
1,154
Reaction score
305
Age
54
Location
Southern Maryland
I understand that the live video stream is only available on the FIRST device you connect to Solo via WiFi. If you want the video on Tower, connect your Android first, then your iPhone.


Sent from my iPad using Tapatalk
 
Joined
Oct 22, 2016
Messages
80
Reaction score
9
Age
44
Android Asus memo pad v5.0. Tower v4.0 I've never uninstalled tower service so I can't confirm what ever the person above says I've just left it on my device.
 
Joined
Oct 9, 2016
Messages
129
Reaction score
18
Age
42
Services is no longer required for Tower v4 or the newest 3DR app, but with Android versions 4.x on your devices, you are 2 OS versions behind the curve.
That is obvious, but is it the real reason of not getting Live Video Feed and RSSI readings on Tower?
 
Joined
Oct 9, 2016
Messages
129
Reaction score
18
Age
42
I understand that the live video stream is only available on the FIRST device you connect to Solo via WiFi. If you want the video on Tower, connect your Android first, then your iPhone.


Sent from my iPad using Tapatalk
That is a new fact that I have not thought of, but I could not see a reason in it. I am running the 3DR App and Tower on different devices.
But given the fact that I have already installed and run 3DR App, so what can I do to make Tower work? Reset Solo and Controller?
 
Joined
Sep 27, 2016
Messages
1,154
Reaction score
305
Age
54
Location
Southern Maryland
Just connect to the device running Tower first after powering up the Solo and controller. This will hopefully fix your problem.


Sent from my iPhone using Tapatalk
 
Joined
Oct 9, 2016
Messages
129
Reaction score
18
Age
42
Just connect to the device running Tower first after powering up the Solo and controller. This will hopefully fix your problem.


Sent from my iPhone using Tapatalk
That is exactly what I do: I power on Controller, then Tablet, Connect Tablet to Controller's WiFi, Power on Solo, wait until Solo connects to Controller and gets GPS fix and then Power on GoPro. Then run Tower and finally connect Tower to Solo through UDP.
I use the same procedure with 3DR App and it works perfectly! Unfortunately Tower does not...
 
Joined
Sep 27, 2016
Messages
1,154
Reaction score
305
Age
54
Location
Southern Maryland
When are you connecting your iPhone? Sounds like not at all. If that is the case I don't have any advice. I was assuming you were connecting the iPhone first and then the tablet.


Sent from my iPad using Tapatalk
 
Joined
Oct 9, 2016
Messages
129
Reaction score
18
Age
42
When are you connecting your iPhone? Sounds like not at all. If that is the case I don't have any advice. I was assuming you were connecting the iPhone first and then the tablet.


Sent from my iPad using Tapatalk
Maybe I have not made myself clear enough - I do not run both devices at the same time - I either run the 3DR App on my IPhone and it works perfectly or I run Tower on one of my Android devices (ver. 4) and Live Video Feed and RSSI do not work.
I could not compare how 3DR App and Tower work on one and the same device as 3DR App requires a higher version of Android OS (that is why I run it on my IPhone) and Tower requires Android (that is why I run it on one of my Android devices).
I will try run Tower on another device running higher (newer) version of Android and advise.
 
Joined
Oct 9, 2016
Messages
129
Reaction score
18
Age
42
Problem solved!
I run Tower on my brother's Samsung S7 Edge (Android 6.0) and the video feed worked just fine.
So the problem is, as I supposed to, when running Tower on older versions of Android OS (in my case v.4.0).

P.S. I till experienced no RSSI reading on Samsung S7 Edge (Android 6.0). Just dashes "----". Has anyone else experienced similar problems?
 
Joined
Jun 5, 2016
Messages
342
Reaction score
38
Age
69
That is a new fact that I have not thought of, but I could not see a reason in it. I am running the 3DR App and Tower on different devices.
But given the fact that I have already installed and run 3DR App, so what can I do to make Tower work? Reset Solo and Controller?
The video feed runs on a dedicated port. If it is connected to one device, the other devices are shut out.
 

New Threads

Members online

Forum statistics

Threads
12,095
Messages
141,202
Members
14,016
Latest member
wabknobby