Welcome to 3DRPilots.com

Sign up and join the largest 3D Robotics drone community!

  1. Traumahead

    Joined:
    Jul 22, 2016
    Messages:
    5
    Likes Received:
    0
    Hello,
    I have had my solo since late 16 and had many great flights with it. I have recently had a problem where it would perform well first flight, but then continuously disconnect after getting 10 feet away from base. I read the forums, and it said to recalibrate my sticks ( as I kept getting the warning that solo was connected but no internet ).
    I recently bought the alpha antenna upgrade and those are not working at all. It says its connected on the ground but as soon as taking off, it disconnects ( even less range).
    My phone is a iphone 6 with 10.2 version software, I am afraid to upgrade as I heard that causes even worse issues. I have also flown it with a samsung galaxy A tablet. both have same problem and I have a big shoot coming up.Can you help me?
     
  2. jimloss

    Joined:
    Mar 2, 2017
    Messages:
    315
    Likes Received:
    172
    Location:
    Chicago area
    What is disconnecting? Does your Solo lose connection with your controller and RTL?
     
  3. Traumahead

    Joined:
    Jul 22, 2016
    Messages:
    5
    Likes Received:
    0
    Yes, my drone keeps disconnecting from the controller! It is basically useless at this point! I thought the new alpha antennas would help, but they seem to not connect at all. Do I need to recallibrate again???
     
  4. jimloss

    Joined:
    Mar 2, 2017
    Messages:
    315
    Likes Received:
    172
    Location:
    Chicago area
    You likely have a problem with the WiFi in the controller or Solo. You need to do some basic troubleshooting to isolate the problem to one or the other before trying to fix it.

    The controller acts as the WiFi access point. Turn it on something about the height that you would hold it. Don't turn your Solo on. Connect your device to your Sololink network and see how far you can walk away from your controller without losing signal. You won't be able to keep the connection as well as a working Solo would, but it'll give you an idea of whether or not the Controller is the cause.

    If it's not the controller, then it's the Solo.

    You'll need to pull the failed device apart and fix what's wrong. It'll be antenna, cable connection, or WiFi card.
     
  5. Traumahead

    Joined:
    Jul 22, 2016
    Messages:
    5
    Likes Received:
    0
    3dr said it could be my IMX6 boards in the drone or controller. where can I get those boards???
     
  6. jimloss

    Joined:
    Mar 2, 2017
    Messages:
    315
    Likes Received:
    172
    Location:
    Chicago area
    Try to narrow down whether it's the controller or the Solo that's having the problem.

    For the Solo you can order from here: 3DR SOLO Link (i.MX6) – Current UAS Store

    I wouldn't pay for parts for in the controller unless you were going to upgrade your WiFi card. It's probably cheaper and safer to replace the controller. They have been on eBay lately for as little as $40.
     
    RichWest likes this.
  7. Traumahead

    Joined:
    Jul 22, 2016
    Messages:
    5
    Likes Received:
    0
    Thanks! I walked away from my controller after it linked to my cellphone at least 50 yards and it appeared to stay connected. But it still has that exclamation mark thru the wi-fi bars and says " no internet connection". is this the root of my Problem? I feel like that warning didnt always appear, and while I can fly it occasionally outpast 1000 feet, I feel like my connectivity problems tarted after seeing this warning. Thats when I started trying to recalibrate.
    Thanks again for your help!
    I also just noticed the aplpha panel antennas I bought are 2.4 ghz 7dbi instead of 7.5 db. does that matter?
     
    #7 Traumahead, May 16, 2018
    Last edited: May 16, 2018
  8. jimloss

    Joined:
    Mar 2, 2017
    Messages:
    315
    Likes Received:
    172
    Location:
    Chicago area
    The "no internet" message is normal. The SoloLink is between the controller and attached devices only and has no access to the Internet.
     
  9. jimloss

    Joined:
    Mar 2, 2017
    Messages:
    315
    Likes Received:
    172
    Location:
    Chicago area
    The 2.4 GHz 7dBi Alfa antennas are the correct panel antennas - that's what I use for better distance when flying in open areas.
     
  10. RichWest

    Joined:
    Jun 18, 2015
    Messages:
    2,725
    Likes Received:
    1,382
    Location:
    Chouston, Tejas
    To add to Jim's replies, not that it is needed....just agreeing. Sounds like an antenna issue or a wifi card went bad. I'd buy a used controller, plenty sitting around collecting dust. If it persists, then change out the Solo wifi.

    If you haven't already, put your stock antennas back on the controller, will help you narrow the issue.

    Gotta ask, are you pointing the panels correctly?
     
  11. BigTulsa

    Joined:
    Oct 13, 2016
    Messages:
    227
    Likes Received:
    52
    Location:
    Tulsa, OK
    I really need to get out with the Solo I have modified and do a distance test. I have both the upgraded wifi cards (both controller and Solo) with the Alfa antennas. The antennas were the first thing I got before the wifi card upgrade. Problem is where I've been flying lately (in an open school field surrounded by a neighborhood which I'm assuming is teeming with 2.4ghz interference) is not ideal for a true test of it.
     
  12. kvtv

    Joined:
    Apr 19, 2017
    Messages:
    24
    Likes Received:
    3
    First, I would keep my iPhone 6 on iOS 10, I do.
    Then About the disconnection, I had my Solo do the same thing some time ago while 3DR was up and working. They told me to take the battery out of the controller, not just turn the controller off, but take the battery completely out of the remote controller. (disconnect the wires) - Then wait for some 10 minutes and connect it back in.
    This worked for me, after this, Solo did not disconnect.
     
  13. artcuda

    Joined:
    May 5, 2017
    Messages:
    73
    Likes Received:
    10
    I had a similar problem. The fix was to uninstall and reinstall the solex app. No clue why, but it worked for me. Just a thought.
     
  14. jerryn

    Joined:
    Jun 10, 2017
    Messages:
    199
    Likes Received:
    53
    Location:
    South Eastern Massachusetts
    I know someone who had the same issue after a clash. You should check the videos on how to dissasemle Solo. I think the antenna may be disconnected or very loose.