solo keeps disconnecting

Joined
Jul 22, 2016
Messages
6
Likes
0
Age
51
#1
Hello,
I have had my solo since late 16 and had many great flights with it. I have recently had a problem where it would perform well first flight, but then continuously disconnect after getting 10 feet away from base. I read the forums, and it said to recalibrate my sticks ( as I kept getting the warning that solo was connected but no internet ).
I recently bought the alpha antenna upgrade and those are not working at all. It says its connected on the ground but as soon as taking off, it disconnects ( even less range).
My phone is a iphone 6 with 10.2 version software, I am afraid to upgrade as I heard that causes even worse issues. I have also flown it with a samsung galaxy A tablet. both have same problem and I have a big shoot coming up.Can you help me?
 
Joined
Mar 2, 2017
Messages
352
Likes
204
Location
Chicago area
#2
Hello,
I have had my solo since late 16 and had many great flights with it. I have recently had a problem where it would perform well first flight, but then continuously disconnect after getting 10 feet away from base. I read the forums, and it said to recalibrate my sticks ( as I kept getting the warning that solo was connected but no internet ).
I recently bought the alpha antenna upgrade and those are not working at all. It says its connected on the ground but as soon as taking off, it disconnects ( even less range).u
My phone is a iphone 6 with 10.2 version software, I am afraid to upgrade as I heard that causes even worse issues. I have also flown it with a samsung galaxy A tablet. both have same problem and I have a big shoot coming up.Can you help me?
What is disconnecting? Does your Solo lose connection with your controller and RTL?
 
Joined
Jul 22, 2016
Messages
6
Likes
0
Age
51
#3
Yes, my drone keeps disconnecting from the controller! It is basically useless at this point! I thought the new alpha antennas would help, but they seem to not connect at all. Do I need to recallibrate again???
 
Joined
Mar 2, 2017
Messages
352
Likes
204
Location
Chicago area
#4
Yes, my drone keeps disconnecting from the controller! It is basically useless at this point! I thought the new alpha antennas would help, but they seem to not connect at all. Do I need to recallibrate again???
You likely have a problem with the WiFi in the controller or Solo. You need to do some basic troubleshooting to isolate the problem to one or the other before trying to fix it.

The controller acts as the WiFi access point. Turn it on something about the height that you would hold it. Don't turn your Solo on. Connect your device to your Sololink network and see how far you can walk away from your controller without losing signal. You won't be able to keep the connection as well as a working Solo would, but it'll give you an idea of whether or not the Controller is the cause.

If it's not the controller, then it's the Solo.

You'll need to pull the failed device apart and fix what's wrong. It'll be antenna, cable connection, or WiFi card.
 
Likes: Waveriderz
Joined
Mar 2, 2017
Messages
352
Likes
204
Location
Chicago area
#6
3dr said it could be my IMX6 boards in the drone or controller. where can I get those boards???
Try to narrow down whether it's the controller or the Solo that's having the problem.

For the Solo you can order from here: 3DR SOLO Link (i.MX6) – Current UAS Store

I wouldn't pay for parts for in the controller unless you were going to upgrade your WiFi card. It's probably cheaper and safer to replace the controller. They have been on eBay lately for as little as $40.
 
Likes: RichWest
Joined
Jul 22, 2016
Messages
6
Likes
0
Age
51
#7
Thanks! I walked away from my controller after it linked to my cellphone at least 50 yards and it appeared to stay connected. But it still has that exclamation mark thru the wi-fi bars and says " no internet connection". is this the root of my Problem? I feel like that warning didnt always appear, and while I can fly it occasionally outpast 1000 feet, I feel like my connectivity problems tarted after seeing this warning. Thats when I started trying to recalibrate.
Thanks again for your help!
I also just noticed the aplpha panel antennas I bought are 2.4 ghz 7dbi instead of 7.5 db. does that matter?
 
Last edited:
Joined
Mar 2, 2017
Messages
352
Likes
204
Location
Chicago area
#8
Thanks! I walked away from my controller after it linked to my cellphone at least 50 yards and it appeared to stay connected. But it still has that exclamation mark thru the wi-fi bars and says " no internet connection". is this the root of my Problem? I feel like that warning didnt always appear, and while I can fly it occasionally outpast 1000 feet, I feel like my connectivity problems tarted after seeing this warning. Thats when I started trying to recalibrate.
Thanks again for your help!
The "no internet" message is normal. The SoloLink is between the controller and attached devices only and has no access to the Internet.
 
Joined
Jun 18, 2015
Messages
2,824
Likes
1,445
Location
Chouston, Tejas
#10
To add to Jim's replies, not that it is needed....just agreeing. Sounds like an antenna issue or a wifi card went bad. I'd buy a used controller, plenty sitting around collecting dust. If it persists, then change out the Solo wifi.

If you haven't already, put your stock antennas back on the controller, will help you narrow the issue.

Gotta ask, are you pointing the panels correctly?
 
Joined
Oct 13, 2016
Messages
230
Likes
53
Location
Tulsa, OK
#11
I really need to get out with the Solo I have modified and do a distance test. I have both the upgraded wifi cards (both controller and Solo) with the Alfa antennas. The antennas were the first thing I got before the wifi card upgrade. Problem is where I've been flying lately (in an open school field surrounded by a neighborhood which I'm assuming is teeming with 2.4ghz interference) is not ideal for a true test of it.
 
Joined
Apr 19, 2017
Messages
25
Likes
4
Age
69
#12
Hello,
I have had my solo since late 16 and had many great flights with it. I have recently had a problem where it would perform well first flight, but then continuously disconnect after getting 10 feet away from base. I read the forums, and it said to recalibrate my sticks ( as I kept getting the warning that solo was connected but no internet ).
I recently bought the alpha antenna upgrade and those are not working at all. It says its connected on the ground but as soon as taking off, it disconnects ( even less range).
My phone is a iphone 6 with 10.2 version software, I am afraid to upgrade as I heard that causes even worse issues. I have also flown it with a samsung galaxy A tablet. both have same problem and I have a big shoot coming up.Can you help me?
First, I would keep my iPhone 6 on iOS 10, I do.
Then About the disconnection, I had my Solo do the same thing some time ago while 3DR was up and working. They told me to take the battery out of the controller, not just turn the controller off, but take the battery completely out of the remote controller. (disconnect the wires) - Then wait for some 10 minutes and connect it back in.
This worked for me, after this, Solo did not disconnect.
 
Joined
May 5, 2017
Messages
93
Likes
15
Age
62
#13
I had a similar problem. The fix was to uninstall and reinstall the solex app. No clue why, but it worked for me. Just a thought.
 
Joined
Jul 22, 2016
Messages
6
Likes
0
Age
51
#15
The "no internet" message is normal. The SoloLink is between the controller and attached devices only and has no access to the Internet.
I got a new android "pixel2" phone, as I wasnt sure if my iphone 6s was causing the disconnect problem. It appeared fixed then when it launches the first flight I can fly up to 100 ft altitude, and 300 ft out before it disconnects and returns home. Then the remote just says "no vehicle connected, searching for solo." I shut the drone off, then turn it back on and then the remote reconnects. I launch it on its next flight and it only goes 50 feet away before disconnecting, every flight after. Why would it connect but have this prob??
 
Joined
Jun 10, 2017
Messages
214
Likes
56
Age
55
Location
South Eastern Massachusetts
#16
Download a Wifi Analyzer for your phone. Scan for Access Points that could be possibly causing interference. Get some Alpha antennas.. big bang for the buck. Just search this forum, you will find them. Try it to see if that helps.

Just be happy you configured RTH! If you didn't you would be dealing with flyaways or hovering until you have a 4lb bird dropping out of the sky.
 
Joined
Aug 31, 2017
Messages
378
Likes
164
Location
USA
#17
My one work solo just began doing this to me, this past Friday. It would work fine and then randomly disconnect from the controller at a distance that was inconceivable it was having connection problems. I was unable to rectify the issue until I did a battery pull on the controller. I have not seen this issue return yet, though I will wait and see if this has actually been a fixed. Or if it was just a coincidence.
 
Likes: DJMc
Joined
Aug 31, 2017
Messages
378
Likes
164
Location
USA
#18
Two days of field data collection after the battery pull, and I've not seen the issue return yet. Super odd. Does anyone know if the dataflash logs from the Solo would tell us anything?
 

New Threads

Members online

Forum statistics

Threads
11,495
Messages
136,603
Members
13,260
Latest member
niwaliketopills