Solo App doesn't recognize wifi connection.

Joined
May 21, 2016
Messages
4
Reaction score
0
Age
21
image.png image.png image.png I still cannot fly my drone. I need to do the preflight update, but that needs to be done via the 3DR Solo App, which continues to deny the fact that I am connected to my controller's wifi. Because of this, I cannot use my drone at all. Has anyone else experienced this problem? If so, how could I go about fixing it? I attached some photos that prove that I am connected to the wifi, but the app continues to be "checking" for a connection between my phone and the controller.
 
Joined
May 7, 2015
Messages
619
Reaction score
493
Location
Washington, DC
try force closing the app by double tapping home, finding the app and swiping it away. if that doesn't work, try re-installing the app. and finally try taking the battery out of the controller for 10 seconds or so.

if none of that resolves your issue, its time to start a chat with support.
 
Joined
Dec 12, 2015
Messages
5
Reaction score
4
Location
Mohave Valley AZ
I had the same problem a couple weeks ago. I had flown successfully after the last update then, a few days later tried to fly and accidentally reset my controller when powering up (my FLY button sticks sometimes). The WiFi name had reset to default so I logged in with the default password and tried to get past "Preflight Update Required". My iPhone 6s+ kept showing a successful connection and sometimes a banner would appear at the top saying I was connected and touch here to return to app. When I returned to the app it would show I was NOT connected. Any attempt to update the controller or Solo via the app always showed orange dots (like your pic). I also couldn't change the WiFi name & password though the app prompted me to do so.
Tons of reboots, resets, app delete & re-installs wouldn't work. Finally, I did a full reset and re-pairing of Solo & Controller and several more attempts to connect WiFi...no joy.
I e-mailed 3dr support & got the auto response. A few hours later I tried once more to power everything up and suddenly had green dots on the diagram to update the controller & Solo. It took 2 tries but finally worked and got me past "Preflight Update" purgatory. One more power-cycle allowed me to rename the WiFi & password but despite the main app screen claiming "Vehicle Connected" the settings screen still said disconnected and the controller said to press FLY to start motors but wouldn't start them. One more power cycle and finally I had full control and could do calibrations (with one app crash) and set Fly Modes. I'm not sure what finally shook the demons loose but my best guess is the app was the culprit. I'm back to normal use of Solo again. Keep trying and hopefully you'll get past the glitch. (I e-mailed support again with updated info to hopefully help someone else)
 
Joined
Dec 12, 2015
Messages
5
Reaction score
4
Location
Mohave Valley AZ
I should also mention I pulled the controller battery, changed the Solo battery, tried a different GoPro, jiggled gimbal connections and tried my iPad Air2 with no change in the WiFi symptoms. Even more reasons I think it was the app.
 
  • Like
Reactions: cameraguy
Joined
Nov 30, 2015
Messages
23
Reaction score
1
Age
48
Location
Praia do Forte, Bahia, Brazil
I had the same problem a couple weeks ago. I had flown successfully after the last update then, a few days later tried to fly and accidentally reset my controller when powering up (my FLY button sticks sometimes). The WiFi name had reset to default so I logged in with the default password and tried to get past "Preflight Update Required". My iPhone 6s+ kept showing a successful connection and sometimes a banner would appear at the top saying I was connected and touch here to return to app. When I returned to the app it would show I was NOT connected. Any attempt to update the controller or Solo via the app always showed orange dots (like your pic). I also couldn't change the WiFi name & password though the app prompted me to do so.
Tons of reboots, resets, app delete & re-installs wouldn't work. Finally, I did a full reset and re-pairing of Solo & Controller and several more attempts to connect WiFi...no joy.
I e-mailed 3dr support & got the auto response. A few hours later I tried once more to power everything up and suddenly had green dots on the diagram to update the controller & Solo. It took 2 tries but finally worked and got me past "Preflight Update" purgatory. One more power-cycle allowed me to rename the WiFi & password but despite the main app screen claiming "Vehicle Connected" the settings screen still said disconnected and the controller said to press FLY to start motors but wouldn't start them. One more power cycle and finally I had full control and could do calibrations (with one app crash) and set Fly Modes. I'm not sure what finally shook the demons loose but my best guess is the app was the culprit. I'm back to normal use of Solo again. Keep trying and hopefully you'll get past the glitch. (I e-mailed support again with updated info to hopefully help someone else)
Hi, I had same problem yesterday, but my bird was totally functional and updated. My app just did not recognize (even using tower) that Wi-Fi was connected. Tons of reboots without success. After one hour I tried again, at the same place, and it was everything working well. I have no idea what happened and I am trying to understand what happened to avoid future problems but I did not find any info about that.
 
Joined
Aug 10, 2016
Messages
1
Reaction score
5
i'm a newbie who got stuck in the preflight update stage as well. Not exactly sure what I was doing wrong, but this exact process from tech support worked for me:

Hello, Thomas.

Please, perform the following:

1- Factory Reset | 3DR - Drone & UAV Technology
2- Pairing the Controller | 3DR - Drone & UAV Technology
3- First-Flight Update | 3DR - Drone & UAV Technology

At the end, please, power off units, kill the Solo app and follow the next start sequence:

1 Power on the controller
2 Connect to the Sololink (Do not open the Solo app)
3 Power on the Solo
4 Open the Solo app

Please, let me know if you have more questions.

Thank you for your cooperation.
 
Joined
Nov 30, 2015
Messages
23
Reaction score
1
Age
48
Location
Praia do Forte, Bahia, Brazil
i'm a newbie who got stuck in the preflight update stage as well. Not exactly sure what I was doing wrong, but this exact process from tech support worked for me:

Hello, Thomas.

Please, perform the following:

1- Factory Reset | 3DR - Drone & UAV Technology
2- Pairing the Controller | 3DR - Drone & UAV Technology
3- First-Flight Update | 3DR - Drone & UAV Technology

At the end, please, power off units, kill the Solo app and follow the next start sequence:

1 Power on the controller
2 Connect to the Sololink (Do not open the Solo app)
3 Power on the Solo
4 Open the Solo app

Please, let me know if you have more questions.

Thank you for your cooperation.
Thank you, appreciate your cooperation. It was not necessary to do the factory reset and pairing once, after 1 hour, It was everything working well (at the same place). I am trying to understand what happened.
 
Joined
Oct 15, 2015
Messages
1,746
Reaction score
941
Location
Lake Oswego, OR
Occasionally I've had to tell my tablet to "forget this network" (sololink), and then reconnect to it when it discovers it again as a new connection.
 
Joined
Nov 30, 2015
Messages
23
Reaction score
1
Age
48
Location
Praia do Forte, Bahia, Brazil
Occasionally I've had to tell my tablet to "forget this network" (sololink), and then reconnect to it when it discovers it again as a new connection.
Thanks Steve, I didn't try it but certainly I will. I try to understand what happened once 1 hour later (without any changes) It was everything Ok and functional.
 
Joined
Jul 4, 2016
Messages
66
Reaction score
35
Age
56
Location
Vega, Texas
Occasionally I've had to tell my tablet to "forget this network" (sololink), and then reconnect to it when it discovers it again as a new connection.
Same here...Has always worked after telling tablet to forget network. This has happened on IOS and Android.
 
  • Like
Reactions: RENATO TOME
Joined
Sep 25, 2016
Messages
86
Reaction score
18
Age
59
Thanks guys this forum has helped several times now. I hope I can make a difference for someone else sometime.
 
Joined
Sep 2, 2016
Messages
1
Reaction score
0
Age
58
I experienced the same problem and I got very near to throwing my phone, controller and solo against a wall. Followed all official 3DR procedures regarding reset and pairing but it took many attempts before it took hold and I got complete control again.

Glad I've got my baby back now :)
 
Joined
Dec 8, 2016
Messages
25
Reaction score
10
Location
Evans, GA
i'm a newbie who got stuck in the preflight update stage as well. Not exactly sure what I was doing wrong, but this exact process from tech support worked for me:

Hello, Thomas.

Please, perform the following:

1- Factory Reset | 3DR - Drone & UAV Technology
2- Pairing the Controller | 3DR - Drone & UAV Technology
3- First-Flight Update | 3DR - Drone & UAV Technology

At the end, please, power off units, kill the Solo app and follow the next start sequence:

1 Power on the controller
2 Connect to the Sololink (Do not open the Solo app)
3 Power on the Solo
4 Open the Solo app

Please, let me know if you have more questions.

Thank you for your cooperation.
Extremely helpful getting one of my Solos sorted out. The reset/pairing steps worked perfectly and I got both updated. The only problem I'm having now is the app can't find the vehicle. I know the controller and the vehicle are communicating (based on the the light flash sequences). The controller is green in the app but the Solo itself is not being detected. Any insight/ideas?
 
Joined
Dec 8, 2016
Messages
25
Reaction score
10
Location
Evans, GA
Scratch that. Thomas Portwood's instructions were spot on. I'm just an idiot and didn't follow the start up sequence properly.
 
Joined
Mar 30, 2017
Messages
9
Reaction score
0
Age
66
I need to be able to log on Facebook from settings.It says I'm not connected.when I try it comes up registration unsucessful.It's the last step.
 
Joined
May 24, 2017
Messages
2
Reaction score
0
Age
66
i'm a newbie who got stuck in the preflight update stage as well. Not exactly sure what I was doing wrong, but this exact process from tech support worked for me:

Hello, Thomas.

Please, perform the following:

1- Factory Reset | 3DR - Drone & UAV Technology
2- Pairing the Controller | 3DR - Drone & UAV Technology
3- First-Flight Update | 3DR - Drone & UAV Technology

At the end, please, power off units, kill the Solo app and follow the next start sequence:

1 Power on the controller
2 Connect to the Sololink (Do not open the Solo app)
3 Power on the Solo
4 Open the Solo app

Please, let me know if you have more questions.

Thank you for your cooperation.
I'd like to thank you for your help and the awesome info. New solo, after update ect. couldn't connect with solo on the app. But after following your sequence, it worked perfectly. Thanks again.
Tom Roat
 
Joined
Jun 10, 2017
Messages
1
Reaction score
1
Age
26
I found the solution to those that may still be having an issue. If you take all the screws from the controller, find the SD card in the controller. After finding it remove the SD card by pushing on it and pops out. take it out and insert it back. after that reboot solo and the controller should start giving wifi again. You will need to download the preflight update again. After that it should be good to go!
 
  • Like
Reactions: skyhax
Joined
Nov 19, 2017
Messages
1
Reaction score
0
Age
28
I found a way to connect and it works with android and iPhone. Before you connect to the controller make sure the 3dr app on your phone is closed then put your phone in airplane mode then turn on your wifi then connect to your sololink wifi after that open the app and it should connect then turn off airplane and your set to fly ;)
 
Joined
Feb 3, 2018
Messages
1
Reaction score
0
Age
44
Hi All, I bought a 3DR Solo yesterday. I set it up and I was able to use it briefly. I charged it for a while, but when I turned it on the app would not see the vehicle. I was on the right wifi etc., but it showed 'not connected' in the app. I fiddled around with it for hours. Factory resets, reinstalled app etc. turning off cellular etc.. and then finally gave up - thinking I had a broken machine. I returned it to the shop and they kindly replaced it with another new one. Got home, unpacked and set up etc. and reinstalled the app. Still no connection. i don't think it it is anything to do with the controller or vehicle - it's the app!! I'm using an iPhone 6s and I've tried everything now, with no success - I'm really at a loss as what to do!!! I am really peed off - surely getting the app right for a 'smart drone' is basic stuff - not happy. Help!!
 

New Threads

Members online

Forum statistics

Threads
11,993
Messages
140,356
Members
13,921
Latest member
lukestuts