Rottors won't start

Joined
Aug 30, 2019
Messages
4
Reaction score
0
Age
54
I have a brand new Solo that has never been flown. When the bird is connected to the controller, all the lights on the bird are on, but when I press Fly to start the motors - nothing happens exsept for a controller sound( I assume it's the sound that goes along with the action of starting the motors). I'm a newbie, please Help!
 
Joined
Jun 18, 2015
Messages
2,983
Reaction score
1,549
Location
Chouston, Tejas
 
  • Like
Reactions: Mossie
Joined
Aug 30, 2019
Messages
4
Reaction score
0
Age
54
I am well aware of the manual. It doesn't help me with this problem
 
Joined
May 9, 2017
Messages
1,272
Reaction score
502
Age
39
You'll need to be more descriptive as to what the noise is that the controller makes, how long you hold the button, whether you have GPS lock, are you using an app or just the controller. A number of things like this are addressed in the User Manual which I assume is why [along with your 'I'm a newbie' comment] @RichWest was linking it.

Please also do the forum members a favor and use the search tool. Many times issues like this have come up, and many times solutions have been provided. Forum members are [if you ask me] extremely generous with their time. It's a basic marker of respect for other people's time to expend a little bit of your own looking for a solution.
 
Joined
Aug 30, 2019
Messages
4
Reaction score
0
Age
54
Thanks so much for your reply. I looked around for the answer myself, but couldn't figure it out. I'll collect all the info you have mentioned and will post it. From my understanding, I thought that the app was not a must for the motors to start.
 
Joined
Mar 31, 2019
Messages
19
Reaction score
2
Age
63
The app is not a must, when you say you press the “fly” button do you keep it depressed until the bar on the controller loads from left to right? Are the lights, front “white/blue” & rear “red”? does the controller let you know you have enough sats to start motors?
 
Joined
Aug 30, 2019
Messages
4
Reaction score
0
Age
54
OK, the controller makes a short double sound after I press it for about 2-3 seconds. There is no bar that loads on the controller. The lights are white/blue and rear red. The controller says nothing about the sats. Actually it doesn't find GPS and the sats are at 0. Do you have to have sats to start the motors? I just want to know that the start to begin with. The controller says that the vehicle is connected, but there is no internet although the map(position) loads.
 
Last edited:
Joined
Feb 7, 2018
Messages
21
Reaction score
0
Age
59
I have a brand new Solo that has never been flown. When the bird is connected to the controller, all the lights on the bird are on, but when I press Fly to start the motors - nothing happens exsept for a controller sound( I assume it's the sound that goes along with the action of starting the motors). I'm a newbie, please Help!
Your GPS is the problem.
 

New Threads

Members online

Forum statistics

Threads
12,095
Messages
141,202
Members
14,016
Latest member
wabknobby