Resolved: Solo can't pair to controller since I updated to Opensolo 3.0.0

Joined
Jan 19, 2017
Messages
8
Reaction score
3
Age
44
Hi all,
I hope someone can help me, I've tried all I could think of and find in posts.
Here is the situation:
My dron was running the latest official firmware, 2.4.2 on both controller and drone. Every component is original: cube, gps, controller wifi, etc.
I had never opened the drone or modified it. It had the 3dr gimbal, which was also working fine.
Yesterday morning I tested it was working, so I decided to try out Opensolo 3.0.0. I didn't have Solex, so I followed the SSH/SCP method from this link:

Ran the first few commands to mount partitions, no errors, copied the files, no errors, ran the last 2 commands, no errors. Then I rebooted the controller and the drone and waiting. They both rebooted a couple of times, and when they came to rest after all reboots the controller was waiting to press A, and then to pair the drone. The drone arms lights were either all the same color, or 2 front white and 2 read red, can't remember for sure.
I pressed the pair button a couple of seconds, but nothing. I repeated that multiple times waiting a couple of minutes in between. Then I rebooted both again, and tried to pair again, nothing. I tried that many times, and they wouldn't pair.

Next rebooted both with the buttons to factory reset, and they apparently did that just fine, but again would not pair with many attempts.
Next I connected to the controller wifi, confirmed I couldn't connect to drone (10.1.1.10), so I followed the upgrade process again in the controller (copy files, reboot etc).
Still would not connect with the drone.

Next I loaded to the controller only the old official firmware from this link that I found in a forum post:
I followed the ssh/winscp method, not taking out the sd card. So I opened the image on the computer, connected to the solo with ssh, run the first commands, copied the files, ran the last 2 commands. The process seemed to work and the controller was downgraded and asking to do first update before flight, but still not pairing to the drone, so I couldn't actually update with the official app.

Then I opened the drone, took out the sdcard, backed it up to the computer, and loaded the Opensolo 3.0 sdcard image to another card with win32imager, then started the drone and followed the factory reset process (pressing the pair button while booting up). That seemed to complete fine. At the end the cube lights are steady green, and thru a hole in the bottom I see an amber light blinking about once per second on the carrier board or the daughter board attached to it that has the wifi. The drone still will not pair.

Next I took out the gimbal just to have less stuff in the done and better view of the cube lights, took the original card and with win32imager loaded the official inital release (again from this link 3drobotics/open-source). Put it in the drone, followed the factory reset process, at the end the drone has the 2 red and 2 white arms lights, but still will not pair to the controller (controller still running factory firmware).

At this point I have 2 sd cards for the drone, one with the factory firmware, one with the OpenSolo 3.0.0 image.

Then I upgraded the controller again to OpenSolo 3.0.0 following these instructions from pedals2padles I found in another post (involved copied the files with SCP to /log/update folder then running some command to activate). That was successful and the controller is now on 3.0.0. I put in the drone the card with the OpenSolo files, and upgraded again to 3.0.0.

They still will not pair.

In the process I checked the antenna cables are correctly connected in the drone board, with their glue holding up.

I copied the 2.4.2 firmware files from my phone to the computer, so I would use those to flash both to 2.4.2 if needed.

At this point I have tried:
Controller and drone originally in 2.4.2 worked fine.
Controller and drone to Opensolo 3.0, stopped pairing
Controller in factory version and drone in 3.0, no pairing
Controller and drone in factory version, not pairing
Controller and drone both again to 3.0, not pairing.
And I have used a different sd card in the drone for the OpenSolo 3.0 last update, still not pairing.

The only thing I haven't done is open the controller and dump the full 3.0 image to it.

Currently the lights are:
Drone: 2 red and 2 white arms. green steady cube. 1 amber blinking once a second under the board.
Controller: I can see from the bottom a steady red light, a steady green light, and a blinking amber light next to the green. The blinking one does 2 quick blinks, then a short pause, then 2 quick blinks and over and over. The total period is about 1 second.

Does anyone has any idea what's going on?
I would suspect something wrong with the wifi in the drone, but how can I check that? I tried to find ways to connect directly to the drone wifi and couldn't find anything.

Edit: I have a spare cube I bought on ebay planning to do the 5v mod (not modded yet), but I think it's not working because I connected to the computer with USB and doesn't get detected and no lights turn on, so I haven't tried installing that one.


EDIT2 & Solution: I read in some thread someone had a pairing problem and 3dr support advised them to disconnect the controller battery among other things, so I gave that a try, and that was it. After that I was able to pair the drone.
Not sure what's going on with OpenSolo 3.0 or my drone, but I tested to factory reset the drone and the controller again, and they wouldn't pair anymore until I disconnected the battery from the controller for a couple of minutes. So at this point my problem is solved, I just flew the drone a bit.
I hope this helps anyone that faces the same problem with OpenSolo.
As a result at least I have learnt multiple ways to apply the firmware, downgrade, upgrade, and access the drone board, so I guess I gained something from it.

I have to find out why I'm not getting video from the camera but likely I left some cable a bit loose.
 
Last edited:
Joined
Dec 29, 2019
Messages
62
Reaction score
14
Age
54
Website
vsasolutions.com
Victor, my advice is do a factory reset, which I think you still can. Get or buy an Android device. Get Solex. Install Open Solo 4. I did it yesterday, worked great. Flew today, amazing.
 

New Threads

Members online

No members online now.

Forum statistics

Threads
12,286
Messages
142,592
Members
14,295
Latest member
luminofor