Problem Interfacing 3DR Solo Pixhawk with a Raspberry Pi

Joined
May 6, 2019
Messages
8
Reaction score
0
Age
25
I have bought and accessory port breakout board and I am attempting to communicate between a Raspberry Pi and the solo with MAVProxy over serial2 on the Solo. I have already connected to the Solo with Mission Planner over the solo wifi. In Mission Planner I have set SERIAL2_BAUD to 57600 and SERIAL2_PROTOCOL to 1(or MAVLink 1). I know I have wired and configured the Raspberry Pi correctly to use its serial interface. I am using a python console version of MAVProxy and I begin the connection with the following commands:

sudo -s
mavproxy.py --master=/dev/ttyAMA0 --baudrate 57600

But this doesn't work since all I am getting back for the heartbeat is link 1 down
I have read through the 3dr dev pages and tons of forum posts for hours and still nothing is working. I could use some help

Oly
 
Joined
May 9, 2017
Messages
1,277
Reaction score
504
Age
39
I'd start with basic troubleshooting - can you connect with the PixHawk using your serial terminal of choice? No MAVlink, just straight serial connection ?
 
Joined
May 6, 2019
Messages
8
Reaction score
0
Age
25
ill try it. though i have the serial2 tx pin hooked up to an oscilloscope and there is only a constant 3.3v coming out, no matter what i send to the serial2 rx pin
 
Joined
May 6, 2019
Messages
8
Reaction score
0
Age
25
im not getting anything. after serial2 is enabled for mavlink1 in mission planner, does the solo (after a restart) start transmitting immediately to serial2 or is there some sort of handshake that needs to happen?

also i have seen on other forum posts that multiple gcs lead to problems with the solo, do you know if there is any truth to that? from what i can tell the i.Mx6 on the solo acts like a gcs or the controller does.
 
Joined
May 9, 2017
Messages
1,277
Reaction score
504
Age
39
The TX pin from the PIxHawk? That would seem to indicate maybe the port isn't enabled.

Are you able to download the parameter set from thee Cube?
 
Joined
May 6, 2019
Messages
8
Reaction score
0
Age
25
when i connect through mission planner over solo wifi, it is able to download all of the params and ive checked that serial2 is enabled and has the correct baud

thanks for help btw, ive been stuck on this for days. ive been working on this around the clock almost
 
Joined
May 9, 2017
Messages
1,277
Reaction score
504
Age
39
I believe you might need to check the MAV_0_* Parameters. I haven't played around with this personally but a peruse through the Full Parameter Reference leads me to believe you may need to tell the Mavlink instance which serial port to use and what rate to use.
 
Joined
May 6, 2019
Messages
8
Reaction score
0
Age
25
okay makes sense. but when i load the params onto mission planner those don't show up. do you know another way to access those?
 
Joined
May 9, 2017
Messages
1,277
Reaction score
504
Age
39
Guess it would help if I looked at the correct parameter list. This is what happens when I troubleshoot on too little sleep.
 
Joined
May 6, 2019
Messages
8
Reaction score
0
Age
25
i took a glance at that list, what was it for? Thanks again for the help
 
Joined
May 6, 2015
Messages
399
Reaction score
224
Age
58
You did it right to enable Serial2 by setting the SERIAL2_xx parameters accordingly to the desired baud rate and mavlink protocol.

If that’s not working, then test the line with a working serial device, eg an old 3DR telemetry link or the like.

A typical issue is that some wires broke off the main board in case you disassembled Solo sometime earlier. The wires connecting the accessory bay with the main board are pretty much the worst possible quality and will often break loose at the slightest touch.
 
Joined
May 6, 2019
Messages
8
Reaction score
0
Age
25
When I’m back at the lab tomorrow morning I will try using a telem link.

When I took the solo apart today I checked the soldered pins on the ribbon cable. And made sure the cables inside were not broke by using a contuctivity tester. So I’m pretty sure the accessory port is properly connected to the main board
 
Joined
Dec 27, 2016
Messages
68
Reaction score
17
ill try it. though i have the serial2 tx pin hooked up to an oscilloscope and there is only a constant 3.3v coming out, no matter what i send to the serial2 rx pin
Maybe i misunderstood....I am confuse "...no matter what i send to the serial2 rx pin.." .. How could you send data to an Rx pin? Data is sent on the Tx pin, by the sender. The Receiver end would receives the data on the Rx pin. You did mention that you configured the serial interface correctly. I recommend to verify it again...Tx to Rx and Rx to Tx.

T
 
Joined
Aug 12, 2019
Messages
4
Reaction score
1
Age
26
Hi @olytthra @fpvsteve did you have any luck figuring out what the issue is? I am in the same position right now. I connected 5V GND TX RX of the Raspberry pi to the 5V GND serial2TX searl2RX of the accessory port on the solo as per Accessory Bay | 3DR Solo Development Guide .I ensured the SERIAL2_PROTOCOL is Mavlink and SERIAL2_BAUD is 115 to match my mavlink router command. This set up seems to work with an Iris+ when i connect the telem2 of the pixhawk to the Rpi ( I am easily able to connect to mission planner with these settings) Is there anything else I need to do for it to work on the SOLO?

Any suggestions would be appreciated.
Thank you
 

New Threads

Members online

Forum statistics

Threads
12,182
Messages
141,797
Members
14,139
Latest member
superjon