No GPS out of the box and more

Joined
Jun 20, 2015
Messages
201
Reaction score
59
Wondering if anyone here has had the same situation. Unboxed, went through the update process, got the green light to to fly. Went and tried to fly and waited and waited and waited for over 10 minutes to acquire gps. Nothing. I went ahead and recalibrated it, got the green light to fly again, again no signal. I called support and they advised to check gps cable under to make sure it was plugged in and it was. They advised to unplug and plug it back to see if that worked and it didn't.

That was last night and here is the and more part, this morning I did some checking and some people said they were able to go into manual and get up in the air some to get a signal for the first time so I went to manual mode, did that and it crashed. No major damage except for the fact solo will not power back up. The battery lights start up and I hear one motor click and then battery powers back off.

Having flown a cheaper cheerson cx-20 quad for a couple of months and hearing all of the hype of this drone for the past 3 months I was really wanting to have an enjoyable experience. I was even willing to pay over a $1000 for this "game changing" drone... so far it is no better than the cheaper $250 cheerson :(

1. Has anyone else lost power to the solo and if so were you able to reset it?
2. Did anyone else have the same gps issue and if so how was it fixed? Regarding the gps, the cheerson was able to connect within a couple of minutes on the first attempt in the same place where I have been trying to get the solo to connect so I know it is not an obstruction issue.

I'm seriously considering getting a refund and just waiting for version 2 or look at getting something else. I just really wanted this drone to perform as advertised.
 
Yea and did 3DR ask you to post the info to them in support ticket. I would think they would be able to help you diagnose it more.

I personally have no intention of taking off the first time without GPS.
 
  • Like
Reactions: GoodnNuff
This was the first thing I done before calling support. They were able to find them while I was on the phone and Aram was who I was on the phone with. He looked at them and he advised the checking the gps cable, then unplugging and plugging it. After I replied last night that it did not work I have not heard anything back but I'm in the east and support is on the west so I'm okay with that. Being able to call, reach someone and have them help troubleshoot has been a good experience so far.

Attached is the log file. I cannot send the last flight log file because I cannot connect solo. Actually the log file is to large to upload here so here is a link to it.

https://drive.google.com/file/d/0B63UAzSqQ9DscFdVZklTVmw1QU0/view?usp=sharing
 
I flew my first flight today in overcast skies here in Philadelphia and although it took a while (maybe a couple of mintues) I managed to get 10 sats. It seemed like longer but I attribute that to me being ready to put Solo in the air.
 
  • Like
Reactions: AmosMoses
Hey Dodge, I can understand a couple of minutes and yes they do seem like they are very long however I attempted twice for over 10 minutes and it did not lock onto a single satellite.
 
Hey Dodge, I can understand a couple of minutes and yes they do seem like they are very long however I attempted twice for over 10 minutes and it did not lock onto a single satellite.

That sucks. Hopefully you get this resolved quickly.
 
Their is no reason it the world why it shouldn't take less than two minutes and in most cases less than 30 seconds to get a gps fix. My cheap garmin in my truck connects in 10 seconds, my large unit on my boat takes 30 seconds. Heck, the hand held I use on my jet ski take 10 seconds
 
Looks like a GPS problem with the unit. That is 3DR. Flying without GPS in response to that problem and crashing as a result? That is you...
 
  • Like
Reactions: GoodnNuff
Some people have had issues with GPS. Some have had to wait a bit when first firing it up to find satellites, but after that initial time it's much quicker.

I personally would never have flown it in manual mode for a first flight, especially knowing it could be defective. That was a bad move.
 
  • Like
Reactions: GoodnNuff
The only reason I did was because I saw where it was mentioned as a possible fix in some situations so I thought I would at least give it a try.
 
I own several drones, Phantoms, Blades, Yuneec, and an Iris+.
Every single one of them with GPS takes a loooong time the very first time you power them up after shipping to you. On average it takes about 4-6 minutes for that initial GPS search, but each subsequent search is shorter. Now it takes less than a minute most days to get enough sats to fly.
However I remember the 3DR Iris+ took almost 15 minutes to give me green lights indicating it had a GPS lock. In fact I had waited 8-12 minutes twice, with no lock, then called 3DR support who was on the phone with me while we waited the 15 minutes or so. Now the Iris+ locks much faster than the Q500 or either Phantom.
 
Having flown quads and Hexes for awhile, when (if) mine comes in I am going to fly in manual first. With the problems some are having with GPS I see no reason to be in a hurry to let it autopilot for me. I will go all through the setups, leave the props off, work the sticks for proper rotation on the motors, pick it up and move it around in my hand to check for proper corrections. Then put the props on and fly in manual for a little bit, then try the auto modes after I know that the main systems are correct. That way I can trust the manual to switch to if I see any erratic behavior.
Just my .02 . Your mileage may vary..
 
Yep, mine took a while also but also had similar startup times with other gps units (marine applications) when moving a long distance and initializing. Once the sats for that position were locked on future start-ups took a lot less time
 
I received my SOLO system yesterday via Bestbuy order on Tuesday, pickup the free battery 15 miles away and the only battery available in MIAMI. My order at 3DR still stands from 13 MAY (with gimbal). After hours of charging, reading manuals, and and doing the software update it was time to do it.

I fired it up at 6 PM eastern leaving me 2 hours of 3DR customer service left on the west coast, if needed. It ran through the compass calibration fairly easy although it made me move because of magnetic interference. Zero satellites after 20 minutes, umm. I called 3DR-on hold 35 minutes, while on hold I started dissembling the battery compartment where the GPS connections are, 4 visible screws under battery and 3 blind screws behind the plastic canopy which has to be popped off to get at them (I thought it was going to snap in two). Sure enough the GPS antenna was disconnected, I plugged it in and by this time the CS came on I stated my problem. He said this is the first time he's heard this, I said...well I've read the forums saying this is happening, by this time my Note Edge was about to die, couldn't get this external battery for the phone hooked up quick enough so I lost 3DR CS. He (CS) did call back and leave a message, so there was follow up.

Meanwhile I went though the procedure for flight and 13 satellites came up, this was a test run so no props but the motors fired up with throttle response. I walked around and watched the distance indicator and it showed I was 84 feet from HOME which was about right, I feel pretty confident everything is working as needed for future flights, more to follow.
 
I just got mine today and everything was going great up until the controller went to connect to the solo. after restarting everything and triple checking everything, I took it outside, the front yard the back yard down the street in a field and the same thing happens, Magnetic Interference.
going to try one more time in the morning and if it is the same its going back to Best Buy.
I have looked all over the web and the only other thing I see is the magnetometer needs replacing. I cant get into solo to do the calibrations, anything I could be doing wrong?
 
Well be careful around concrete or places with underground wiring or pipes.

I needed to keep mine off the concrete because of all the rebar. Sounds like you were in grass but thought I would mention that.
 
OK, I got her flying this morning, all I can say it is an awesome machine!
I found out that when first getting this drone to start up it is like some here say, very sensitive, but once I took it to a large parking area, away from trees, high wires, buildings and basically at least 60 feet away from even my truck and presto no Magnetic Interference!!
a lot of good info here on this website, so I'm grateful to one and all.
also to get video you really have to push that connecter in firmly to the GoPro.
 
  • Like
Reactions: Raybro

Members online

Forum statistics

Threads
13,106
Messages
147,826
Members
16,087
Latest member
caseyKoehn