mRo GPS issues

Joined
Jan 20, 2017
Messages
198
Likes
82
#1
The first few times I used it I was getting a lock of at least 11 sats and an HDOP of .8 in less than 45 seconds Now it takes 2 minutes to get a lock with 8 sat HDOP of 1.8 in the exact same location and time of day. The main problem is now every time I take out I get a lost gps alert that lasts a few seconds. I replaced it with the rev b stock gps that is faster and has no problem keeping the lock. I sent a email last week for a rma and spoke to Chris from mRo who called me. I told him I wanted a refund and he said he would email me a rma which i'm still waiting for.I have since sent them 2 more emails for the rma with no response .
Edit
I just got my Rma
 
Last edited:
Joined
Sep 27, 2016
Messages
1,154
Likes
301
Age
53
Location
Southern Maryland
#2
Are you trying to ask a question or just trash on mRo?
I think the vast majority of folks flying the mRo M8N GPS have been extremely happy with it (including me). Sounds like you got a dud.
How long has it been since Chris promised to mail you the rma?
 
Joined
Jan 20, 2017
Messages
198
Likes
82
#3
Yes I believe I got one that went bad and I'm just stating facts to help others that might have similar issues
 
Joined
Apr 28, 2016
Messages
29
Likes
3
Age
44
#7
Hmm I'm experiencing a similar issue. Used to boot up and lock quickly now it takes it time with a lower number of satellite. Anyone else experiencing this? The GPS has been in about a year.
 

New Threads

Members online

No members online now.

Forum statistics

Threads
11,495
Messages
136,603
Members
13,260
Latest member
niwaliketopills