Iris+ issues

Joined
Aug 5, 2018
Messages
6
Likes
1
Age
58
#1
having some issues with my Iris+ lately will not arm. lost all telemetry, and generally acting weird, looks like a programming issue, is there a way to default back to factory specs,,
I am familiar with droid planner, but reluctant to try, I would be willing to send it to someone who can take care of this and pay you for your time
let me knw
thanks
 
Joined
Mar 2, 2017
Messages
58
Likes
2
Age
58
#2
Hi Bill, If you should find the fix, please let me know as I have had the same issue and reset it to factory reset and used Mission Planner and still no go. So, it's something that I'm not doing. It's just not receiving the telemetry. Other than that, all is good. If you find the resolve, please do not hesitate. Thanks, Bob
 
Joined
Aug 5, 2018
Messages
6
Likes
1
Age
58
#3
I think Ive exhausted all my remedy's, and sadly I have to assume the flight controller is toast, I suppose Ill use it for parts, I already have another on the way, as I love having the Iris in my stable,,, If find the issue Ill post it
 
Joined
Mar 2, 2017
Messages
58
Likes
2
Age
58
#4
As far as my issue and the telemetry not transmitting back to the controller, I don't think the controller is the problem. I believe it was the idiot behind the controller, in that he copied and then deleted accidently the original firmware and then tried restoring it and at that point it was a battle of the data. I know it can be done, just how, is the question. I hope that your new controller is the fixall. Thank you for your response and best of luck! Look forward to the hooray! Bob
 

New Threads

Members online

Forum statistics

Threads
11,611
Messages
137,185
Members
13,340
Latest member
TakwaD