Completed Pixhawk 2.0 5V jumper mod....observations....

Joined
Jul 15, 2017
Messages
55
Reaction score
17
Age
37
Location
Denville, NJ
Completed the mod, for me not to bad a job considering I had 10x magnification available to inspect the work as I went and hot air gun made removing the buffer a breeze.....I installed the 3.5.4 update in the SOLO firmware folder using WinSCP and restarted and it was literally that easy and done......I know many have not done this mod but this list and future additions will give others a heads up.....

Initial observations and please feel free to add to the list.....

-The independent smart battery cell voltages constantly reports all 4 cells at 3.8v no matter the state of charge

-The signal sensitivity on the top right of the SOLEX app displays in a low number like 5 db right next to the SOLO which typically would display 50 db previously
 

Attachments

Joined
Oct 13, 2016
Messages
230
Reaction score
53
Location
Tulsa, OK
Interesting. This mod (or something to this effect) was made to my Solo last month by my brother and none of those side effects happened (3.8v reported by all cells, the losing of a digit on the RSSI db scale). I'm also running 3.5.4.
 
Joined
May 6, 2015
Messages
388
Reaction score
216
Age
58
Interesting. I am running 3.5.4 on an unmodified stock 2.0 cube in Solo. Cell voltage and signal strength in Solex have been always correctly displayed. This should have nothing to do with the AC version nor with the cube itself.
 
Joined
May 12, 2017
Messages
16
Reaction score
1
Age
42
Location
Good ol' Europe
The system connector looks a little bit toasted... The contacts are fine, but the plastic is definitely melted. It can cause problems - just my 2 cents. When doing such surgery you should cover the rest of components with aluminum foil. Also a good temperature controlled hotgun on rework station could help.
 
Last edited:
Joined
Jul 15, 2017
Messages
55
Reaction score
17
Age
37
Location
Denville, NJ
The system connector looks a little bit toasted... The contacts are fine, but the plastic is definitely melted. It can cause problems - just my 2 cents. When doing such surgery you should cover the rest of components with aluminum foil. Also a good temperature controlled hotgun on rework station could help.
Cube is working after a review of the pixhawk parameters many changes were made and its up and flying, the connector fit right on its mating connector with no issue its discolored and has no effect electronically.
 
Joined
May 12, 2017
Messages
16
Reaction score
1
Age
42
Location
Good ol' Europe
That connector has around 80pins, as I remember correctly. Just to "work" and "make changes" I don't think you need more than 20. If 2-3 pins are pushed wrongly becaused of the deformed plastic it can cause the described symptoms. And if you look closely on the pictures you can see that deformation, not only discoloration. If you like the challenges, you can search for schematics on github and make some measurements, so you can figure out what's wrong.
Another quequestions: did yo powered it up right after the surgery (before fw update)? Those symptoms were already present?
 
Joined
Jul 15, 2017
Messages
55
Reaction score
17
Age
37
Location
Denville, NJ
That connector has around 80pins, as I remember correctly. Just to "work" and "make changes" I don't think you need more than 20. If 2-3 pins are pushed wrongly becaused of the deformed plastic it can cause the described symptoms. And if you look closely on the pictures you can see that deformation, not only discoloration. If you like the challenges, you can search for schematics on github and make some measurements, so you can figure out what's wrong.
Another quequestions: did yo powered it up right after the surgery (before fw update)? Those symptoms were already present?
Im going to repeat again, after adjusting a few parameters in 3.5.4 it appears the cube is working as expected, flight is way more responsive with the 5v mod, most of the parameter problems were with the GPS settings they were not compatable and creating EKF errors and causing the erratic flight and also the telemetry on the transmitter was not as expected due to the cascading EKF errors that the parameters were causing.....I have completed 2 flights on 2 fully charged battery packs and its never been better I locked 25 sats at a .5 hdop and no ekf errors and she is more zippy than ever due to the absence of the slew rate the flight controller is given in the crippled firmware, now with the 5v mod and corrected parameters I couldn't be happier with the performance and it made the little bit of headache and reading up well worth it and I didn't have to spend 170 for a green cube.......this is not plug and play and some parameters need to be adjusted.......
 
Last edited:
Joined
Apr 18, 2018
Messages
91
Reaction score
33
Age
37
I'll be doing/attempting this soon because:
1) the ellusive green cube is in hiding again
2) the black 2.1 cube is the same price as a green cube if you are lucky enough to find one without the carrier board but it still needs the 5V mod
3) most importantly, a stock 3dr pixhawk 2.0 can be had for relatively cheap

This mod will hold over my "thrill" need until I can find a green cube
 
Joined
Jul 15, 2017
Messages
55
Reaction score
17
Age
37
Location
Denville, NJ
I'll be doing/attempting this soon because:
1) the ellusive green cube is in hiding again
2) the black 2.1 cube is the same price as a green cube if you are lucky enough to find one without the carrier board but it still needs the 5V mod
3) most importantly, a stock 3dr pixhawk 2.0 can be had for relatively cheap

This mod will hold over my "thrill" need until I can find a green cube
If you could do it you will enjoy the responsiveness of the 5v pwm signal but this is no plug and play mod
 
Joined
Apr 18, 2018
Messages
91
Reaction score
33
Age
37
The toughest part of this mod is the 5 volt mod itself, other than that its straightforward...
My only question is what type of wire/insulation is recommended for the 5V? I don't recall any specifics on this, but I can go back to searching the forums.
 
Joined
Jul 15, 2017
Messages
55
Reaction score
17
Age
37
Location
Denville, NJ
My only question is what type of wire/insulation is recommended for the 5V? I don't recall any specifics on this, but I can go back to searching the forums.
I opened a relay that had enamled copper wire wound around its coil of the appropriate gauge, too small a gauge is no good, enough gauge to safely handle any current it will utilize, its sold in spools called enamled copper wire but honestly its pretty much wound on any small magnet device you have lying around like transformers, relays, reed switches, etc......
 

Attachments

Joined
Jul 15, 2017
Messages
55
Reaction score
17
Age
37
Location
Denville, NJ
I posted pictures so you can visually see the gauge of wire i used its actually a few strands of enameled wire wound together to make up a fair size gauge wire, this important thing is to track the wire in a way that it wont short on other devices and conformal coat the wire to the board to prevent damage from vibration
 
  • Like
Reactions: backcountryice
Joined
Dec 18, 2018
Messages
3
Reaction score
0
Age
40
It's not clear in most of the modding instructions for this but can this initially be ran on stock solo firmware without any modifications or does anything need to be changed? Just tried the mod myself but it's not starting the motors and repeatedly states "calibrating sensors" when starting it up when it's searching for satellites.

I'm basically wondering if the 3.5.4 update is needed? I just want to test functionality before going forward with anything further unless I need to . I'm going to upgrade anyhow soon but want to make sure I didn't botch the thing before doing so.
 
Joined
Mar 12, 2016
Messages
3,606
Reaction score
2,404
It's not clear in most of the modding instructions for this but can this initially be ran on stock solo firmware without any modifications or does anything need to be changed? Just tried the mod myself but it's not starting the motors and repeatedly states "calibrating sensors" when starting it up when it's searching for satellites.

I'm basically wondering if the 3.5.4 update is needed? I just want to test functionality before going forward with anything further unless I need to . I'm going to upgrade anyhow soon but want to make sure I didn't botch the thing before doing so.
The firmware doesn't know or care about this. If you can't get it to calibrate, you probably broke it.
 
Joined
Dec 18, 2018
Messages
3
Reaction score
0
Age
40
It stopped the calibration attempts after 3 popups, It wasn't so much that it never stopped the calibration attempts, they stopped after a few. I'm more worried about it stating ready to fly then the motors don't turn. I'm getting other advice elsewhere that this may need the upgrade. The piece hadn't been flown in about 3 months as well and was in a new area with drastically different temperature so I'll have to try again when I get time and check if the higher than usual calibration attempts are a re-occurring thing. Time is not a thing I have right now but I'm going to get it out and try again soon.
 
Joined
Mar 12, 2016
Messages
3,606
Reaction score
2,404
No, you don't need the upgrade. Whoever is telling you that doesn't know what they're talking about. Although I don't know why you'd do the 5v modification and then not do the upgrade, since that's the whole reason for doing the mod.

Just redo the level calibration if need be.
 
Joined
Dec 18, 2018
Messages
3
Reaction score
0
Age
40
Took it apart again, seems the pin/trace for the 5v snapped off when I was gluing the wire down. Could not re-attach in any way, or remove the buffer IC once I had the wire adhesive on it so yeah that cube is borked. I have another cube, anyone here do 5v mods and want to PM me rates? I don't want to risk ruining my second and am wanting to compare the costs of just getting a green cube to having someone mod my second cube. I could probably pull it off the second try but I'm just not going to attempt this again probably.
 

New Threads

Forum statistics

Threads
11,809
Messages
138,956
Members
13,608
Latest member
Faust Rod