Welcome to 3DRPilots.com

Sign up and join the largest 3D Robotics drone community!

  1. n8lbv

    Joined:
    Jan 1, 2017
    Messages:
    108
    Likes Received:
    9
    I'm using Tower and would like to do a test mission on huge open land and have it NOT return home as the signal from the TX goes in and out a bit as it gets
    2000-3000 Ft. out in front of me.
    The other thread I linked suggests this is the setting for that.
    I thought *this* essentially was the RC override function.
    Can you not actually invoke RC override via this setting and flying in "auto mode".
     
    JRW likes this.
  2. Pedals2Paddles

    Joined:
    Mar 12, 2016
    Messages:
    2,982
    Likes Received:
    1,815
    RC override means using a PC gaming joystick connected to the PC running mission planner to fly the drone. Clearly that's not what's going on here. So that's why I say it is unrelated.

    FS_THR_ENABLE is the parameter you need to set. Use 2, which is RTL but continue with mission in auto.
     
  3. n8lbv

    Joined:
    Jan 1, 2017
    Messages:
    108
    Likes Received:
    9
    Thanks!
    I've been reading and did see that.

    I'll eventually test it Very_Carefully In miles of open field.
    I also run an independent tracking beacon transmitter that has it's own 1 year battery in the event I ever crash in tall weeds
    or corn I can find the thing.
     
  4. n8lbv

    Joined:
    Jan 1, 2017
    Messages:
    108
    Likes Received:
    9
    I'm flying 1.5.3
    Noticed today that at 20% battery it wants to return home no matter what.
    I hit the pause button as I was about 50 ft. from home and just wanted to manually land it.
    I noticed that I had no forward and back controls at all and the camera on it's own pointed straight down as soon as it started doing this.
    I don't remember exactly what happened but I somehow was able to force it down with the throttle control and I was not able to move it laterally.
    I'll need to play with this more to see what the deal is..
    It's obvious that overriding the RTH (RTL) was not wanting to happen.
    I'll play some more but frio what I can tell it just keeps going back into RTL mode no matter what I do at 20% battery.
    Thoughts?

    And how *should* it be behaving at 20% battery or when it is in Auto RTL...
    How do you properly override it and stop it from jumping right back into that mode again?

    Flight video included here:

     
  5. FamilyFlyGuy

    Joined:
    Jan 15, 2017
    Messages:
    84
    Likes Received:
    30
    Location:
    Eastern PA
    Could the other drone flying there interfere with yours? timeline @ 4:50
     
  6. n8lbv

    Joined:
    Jan 1, 2017
    Messages:
    108
    Likes Received:
    9
    No sir it was not interfering.
    1. DJI lightbridge does not interfere with Wifi.
    2. I had solid video and telemetry working between the controller and the Solo.
    3. I've had this happen before with nobody else operating anything and in the middle of nowhere.

    I need to study what is actually happening when the battery reaches 20% and the alarm is going off and not be in such a panic to land it or stop it from flying up to 150FT
    (where I have it set) for RTL.

    What should it actually do in this 20% state?

    My expectation is that you should be able to just push pause or FLY (I have that mapped to button A) and manually fly it on low battery.
    It seems as if it is fighting this somehow.

    Again I need to test and observe better.
     
  7. n8lbv

    Joined:
    Jan 1, 2017
    Messages:
    108
    Likes Received:
    9
    My best guess when the stick did not respond was because it went back into RTL (on its own)mode AFTER I hit pause or fly. being at 20% battery.
     
  8. Pedals2Paddles

    Joined:
    Mar 12, 2016
    Messages:
    2,982
    Likes Received:
    1,815
    First, 20% has nothing to do with it. The very beginning of this thread describes the distance based battery failsafe. It also describes the parameter you need to adjust to make that work properly. So I"m not going to repeat that all again.

    Now, once the battery failsafe kicks in, you should be able to push pause or fly to take over. You should also be able to control yaw and gimbal pitch during RTH. Copter pitch, roll, and throttle sticks will have no effect during RTH. If you were getting no response from any of these inputs, then you're Solo was malfunctioning.
     
  9. n8lbv

    Joined:
    Jan 1, 2017
    Messages:
    108
    Likes Received:
    9
    That's alright and I did read it back when it was posted.
    20% Aproximately where battery failsafe was kicking in and not an exact number.
    I also went back and read it again. and that was not anything I was expecting you to repost or answer.

    Right! and I felt as if it went back into RTL after I hit pause and/or fly.
    I need to re-test and pay better attention to what is going on here after I try to cancel RTL.
    All of my testing is being done very close to RTL point and not where it's too far to fly back even if I let it go up to my RTL altitude and come back.
     
  10. n8lbv

    Joined:
    Jan 1, 2017
    Messages:
    108
    Likes Received:
    9
    Finally was able to do a test flight..
    It started to RTL at some point soon below 20% battery.
    Hit the pause button.
    It stopped and stayed as expected.
    Had full manual FLY controls.

    Manually lowered it set it down and shut off the motors.
    All worked as expected.
     
  11. mwizard

    Joined:
    Apr 10, 2017
    Messages:
    9
    Likes Received:
    1
    Location:
    Fallbrook, CA
    How do I check to see which version I have? Anything special to do upgrade w/ a Mac?
     
  12. Stealth

    Joined:
    Oct 9, 2016
    Messages:
    126
    Likes Received:
    18
    While connected to Solo and Controller Open 3DR App then open settings and finally System Info. Have a look at Autopilot ver. I am sending a screenshot of mine. Still running Autopilot 1.3.1.
     
  13. Stealth

    Joined:
    Oct 9, 2016
    Messages:
    126
    Likes Received:
    18
    IMG_6074.PNG Here it is!
     
    mwizard likes this.
  14. mwizard

    Joined:
    Apr 10, 2017
    Messages:
    9
    Likes Received:
    1
    Location:
    Fallbrook, CA
    Stealth, I have the same versions as you do. Why have you not updated your autopilot version? Any instructions for doing it w/ a Mac?
     
  15. carpy

    Joined:
    Mar 10, 2016
    Messages:
    225
    Likes Received:
    81
    Location:
    Plymouth, MN
    Instructions are the same. Use FileZilla Client for Mac OS.
     
  16. Stealth

    Joined:
    Oct 9, 2016
    Messages:
    126
    Likes Received:
    18
    To cut a long story short I had to change the Pixhawk of my Solo and I am still testing it. That is why I have not updated Ardupilot to last f/w.
     
  17. Toiletbowl

    Joined:
    Jul 1, 2015
    Messages:
    654
    Likes Received:
    165
    so what is the most stable 1.5.2 or 1.5.3 before i proceed to reflash :)
     
  18. Pedals2Paddles

    Joined:
    Mar 12, 2016
    Messages:
    2,982
    Likes Received:
    1,815
    You should use 1.5.3
     
    Toiletbowl likes this.
  19. Dmitry

    Joined:
    Aug 22, 2015
    Messages:
    358
    Likes Received:
    62
    I returned to 1.3.1
    1.5.3 firmware was not stable for me, then the spherical panorama refused to work until the end, then I skipped the calibration error. It was exhausted, rolled back to 1.3.1 and everything became great
     
  20. Toiletbowl

    Joined:
    Jul 1, 2015
    Messages:
    654
    Likes Received:
    165
    updated now next is to tuneup :)
     

    Attached Files:

    carpy likes this.