2 yellow lights back red green up front

Joined
Jul 8, 2022
Messages
29
Reaction score
3
Age
38
Hi guys, i got my drone from ebay with open solo 4.0 and a modded 2D cheap gimbal on it. When i installed Solex and turned it al on it worked fine but almost back landing after a 2mins test flight all of a sudden my controller lost signal and went into waiting for solo mode as the solo excecuted a RTH landing. Since then the controller stays in that mode and the drone is no longer to be connecting or pairing. Also tried battery remove and sd re-insert. Nothing seems to make any change. The lights after startup are 2 yellow on the back and green red on the front. Can anybody help me fix this ?
 
Hi guys, i got my drone from ebay with open solo 4.0 and a modded 2D cheap gimbal on it. When i installed Solex and turned it al on it worked fine but almost back landing after a 2mins test flight all of a sudden my controller lost signal and went into waiting for solo mode as the solo excecuted a RTH landing. Since then the controller stays in that mode and the drone is no longer to be connecting or pairing. Also tried battery remove and sd re-insert. Nothing seems to make any change. The lights after startup are 2 yellow on the back and green red on the front. Can anybody help me fix this ?
That light pattern is correct for a SOLO running OS 4.0 or 4.01. It's possible the controller browned-out and lost the signal, which would cause a RTH to be executed. Without knowing any more details, I'd try pairing again with both controller and flight battery fully charged. Keep us posted and GL!
 
  • Like
Reactions: Basho
That light pattern is correct for a SOLO running OS 4.0 or 4.01. It's possible the controller browned-out and lost the signal, which would cause a RTH to be executed. Without knowing any more details, I'd try pairing again with both controller and flight battery fully charged. Keep us posted and GL!
What SD card did you remove?
 
From the controller as thats the least problematic i suppose.
I removed it not completely but took it out and pushed it back in place after gently removing the bit of glue holding it stuck.
 
I removed it not completely but took it out and pushed it back in place after gently removing the bit of glue holding it stuck.
I do have another controller that is stuck in preflight mode b.s that i used on a stock solo. Can i try giving that one a attempt to pair/bind to the recent current solo 4.0 we now talking about or is that totally pointless ?
 
I do have another controller that is stuck in preflight mode b.s that i used on a stock solo. Can i try giving that one a attempt to pair/bind to the recent current solo 4.0 we now talking about or is that totally pointless ?
That might be worth a try, IDK. It doesn't sound like a firmware issue as it was flying I think you said. I had a similar issue. In that case the Solo experienced a brownout while landing ( I was able to confirm this from the dataflash log) and entered RTL - had no control as the controller said "Waiting...". This was my fault obviously for pushing a battery, and after recharging everything was normal. If you get bound again I would definitely check the log.
 
That might be worth a try, IDK. It doesn't sound like a firmware issue as it was flying I think you said. I had a similar issue. In that case the Solo experienced a brownout while landing ( I was able to confirm this from the dataflash log) and entered RTL - had no control as the controller said "Waiting...". This was my fault obviously for pushing a battery, and after recharging everything was normal. If you get bound again I would definitely check the log.
With saying pushing the battery i assume u mean running it to low in power percentage or not ? And iff thats so than it cant be the same cause as mine was full and maybe 2 or max 3 lights down from the indicator lights . It flew like 2mins and went into RTH going up first while it was pretty much closest to me from the moment it went up. Aka it shouldnt be doing that specific thing as it wasnt doing it when it was 10 times that distance further removed from me. In terms of logic and assumption that is ofc. But both Solex as the controller are not getting a connection with Solo. Is the sololink wifi comming from the drone or the controller? It does recognise or displays the wifi signal itself but doesnt connect to it. Weard as it says connected but without internet ability. Plus while saying that on the phone wifi function it also in Solex says in the top right corner its connected with wifi sololink while it keeps searching and failing to find Solo as the device i have selected to connect with. The solo voice repeats endlessly the message "if this is the network/wifi you like to connect to press connect button again/one more time. When doing that the whole thing repeats again by failing and saying little later to press connect if this is what i want to connect to etc etc etc.....
 
And im not sure i have a log as Solex was turned on but in the 2mins flying i did not check or seen any of the parameters. Or am sure i had the save logs function turned activated if it was available to do so. But ill try to find out if i got any log of it. Thnx for the help and your time for now m8. I appreciate it big time :)
 
Did you try factory reset on the controller? You may need to format and reflash the SD card.

Also here's a video of how you can pair and update the firmware in a couple of different scenarios in case you need to use a different controller.

To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.
 
The technique in the video from JB above definitely works. I have done it successfully here.
Big thnx bro, u also know what should be prefered to. Because i have 3 controllers. Besides the original the seccond working correct but without the wifi password that i once changed(yeah im a real true fckn idiot) and forgot about wich created a bigger issue to get solved as i expected. And a 3rd technically good controller that is stuck in preflight update mode and needs to be updated is what it says. Also that sounds more simple and quick easy to me and my knowledge/experience in getting that succesfully accomplished.

To end im having most likely the Tlogs available to share of the first short and only flight that i described and where the problem must have occured . Anyone that i can send it to that possibly can extract info out of it that is in maybe any way relevant or helpfull to be helpfull or of any use or positive purpose? Even if its to prove/show the seller it had the problem without me being the cause of it myself , that im convinced of it cant be the case. I destroyed to much birds by now and had a decent amount of previous Solo's to make such things happen myself and not realise at least it is my own dumbfuckk idiocracy responsible hahaha :(
 
Did you try factory reset on the controller? You may need to format and reflash the SD card.

Also here's a video of how you can pair and update the firmware in a couple of different scenarios in case you need to use a different controller.

To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.
Update i also posted as reaction in another thread having the simular problem unto this point. IM HERE WITH A POSITIVE UPDATE !!!

Hey guys my unit had the exact b.s but now after switching some likely wrong damaged or none working parts with 2 units into hopefully a working good one. I was stuck in the good match but with the same exact problem of the leds indicating the same colour combintion and no possibility to make any change happen to pair the mofos. Pair button didnt react to whatever time being pressed besides the little light next to it responding and giving confirmation that the pressing did happen correctly or at least responded as such. Now after combining 2 broken solo b.s units into the hope of having a good one. I progressed into having the next problem of they did pair but mismatched as the final result where progress is not possible unless i update open solo to the correct one. The unit is as far as i know having stock or at least old outdated firmware while the controller has the newer 4 0 open solo on it. I assume to update it means the firmware of the solo unit itself and not the controller that logicly would need a downgrade to make it match in terms of firmware versions.?!?!?. Now the million dollar question. As my drone shows no longer the 2 rear yellow and front red green colours but 2 red 2 white lights same colour on both ends. And is that better compare to the status of the previous colour combination haha? Lastly , is there a easy way to put the firmware i need on the solo that a mentally retarded idiot like me should be getting done wthout a big potential to fail at it ? Thnxxx for al your wisdom and help to this point and really will me in extacy if more of that ends up in me.flying the damn biatch machine from hell xD
 
Big thnx bro, u also know what should be prefered to. Because i have 3 controllers. Besides the original the seccond working correct but without the wifi password that i once changed(yeah im a real true fckn idiot) and forgot about wich created a bigger issue to get solved as i expected. And a 3rd technically good controller that is stuck in preflight update mode and needs to be updated is what it says. Also that sounds more simple and quick easy to me and my knowledge/experience in getting that succesfully accomplished.

To end im having most likely the Tlogs available to share of the first short and only flight that i described and where the problem must have occured . Anyone that i can send it to that possibly can extract info out of it that is in maybe any way relevant or helpfull to be helpfull or of any use or positive purpose? Even if its to prove/show the seller it had the problem without me being the cause of it myself , that im convinced of it cant be the case. I destroyed to much birds by now and had a decent amount of previous Solo's to make such things happen myself and not realise at least it is my own dumbfuckk idiocracy responsible hahaha :(
Agree, sadly, that most problems are self-induced. If you have the .bin file or can eventually get it I could take a look. If you did have a successful flight with that bird, I would discount a firmware issue. I can also say I've had one or two totally unexplainable events with OpenSolo 4. One time, after a perfectly normal flight/landing, I took off again and all the controls were reversed. Landed again, and everything was normal. At all times the bird was in front of me. Go figure. Post the .bin if you can.
 
Agree, sadly, that most problems are self-induced. If you have the .bin file or can eventually get it I could take a look. If you did have a successful flight with that bird, I would discount a firmware issue. I can also say I've had one or two totally unexplainable events with OpenSolo 4. One time, after a perfectly normal flight/landing, I took off again and all the controls were reversed. Landed again, and everything was normal. At all times the bird was in front of me. Go figure. Post the .bin if you can.
I am now in a very different state with my setup that sort of looks very promosing. I appreciate it if u are willing to read my posts on the vid i put them to have the info in the most easy accesable manor. Its having pretty radical progress but with a few new crazy unexpected problems ofc pfff. Hope someone from here can get me proceeding. I never am ungreatfull but the help from the vid uploadeder doesnt seem to notice the lvl of understanding and help i need to go on. Because all his help so far is shit the noob i am already done and isnt the reason of the new problems neither ofc a fix. So yeah i need all the help i can get !!!! Heres the link.

To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.

Im AIRoboticOverlord Nicknamed :)
Thnx and sorry for bothering u with my spamm. English is not my mother language therefor i need lots of txt to describe shit correctly..
 

New Posts

Members online

Forum statistics

Threads
13,101
Messages
147,797
Members
16,077
Latest member
jollyrancher99